Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#19144 closed defect (invalid)

Recent FindwxWidgets.cmake (3.19) script stops at wxWidgets-3.1.0 on Windows CMake (Nov 2020)

Reported by: mick-p1982 Owned by:
Priority: normal Milestone:
Component: build Version: 3.1.1
Keywords: CMake Cc: holy@…
Blocked By: Blocking:
Patch: no

Description

There seems to be a regression on the find-package scripts shipped with CMake. After I upgraded to a late 2020 version of CMake it no longer works with wxWidgets versions after 3.1.0 because these versions are hardcoded into the script and stop at 3.1.0.

More background: https://forums.wxwidgets.org/viewtopic.php?f=19&t=48212

Attached is the script that comes with CMake 3.19 for Windows. The link explains the version table in the script. Maybe this has been recognized and fixed in future versions (is a back-fix possible?) but there's no closed ticket about it.

Attachments (1)

FindwxWidgets - Copy.cmake download (43.9 KB) - added by mick-p1982 6 months ago.
CMake find-package script

Download all attachments as: .zip

Change History (10)

Changed 6 months ago by mick-p1982

CMake find-package script

comment:1 Changed 6 months ago by swt2c

I think that you need to report this to CMake and not wxWidgets as CMake provides/maintains that file: https://gitlab.kitware.com/cmake/cmake/-/issues

comment:2 Changed 6 months ago by mick-p1982

  • Cc holy@… added

I'm just reporting the issue, assuming someone here cares about projects being able to find the wxWidgets module on Windows. (It seems strange that someone working at CMake/Kitware would be responsible for a script for wxWidgets? Maybe I misunderstand? Someone knowledgeable of wxWidgets must write such a script.)

Last edited 6 months ago by mick-p1982 (previous) (diff)

comment:3 Changed 6 months ago by mick-p1982

  • Cc holy@… removed

Note, the script says:

AUTHOR Jan Woetzel <http://www.mip.informatik.uni-kiel.de/~jw>

Also note (again) past versions of CMake seemed to work, so it seems like somehow an older script is being shipped with the newer versions of CMake.

comment:5 Changed 5 months ago by vadz

  • Resolution set to invalid
  • Status changed from new to closed

Sorry but I really don't understand how do you expect us to fix a problem in a file distributed with CMake. We do care about people using wx from CMake projects, but we simply have no control whatsoever over it, so I don't think it's useful to keep this ticket open, the one in CMake bug tracker is the one to follow.

comment:6 Changed 5 months ago by mick-p1982

  • Cc holy@… removed

You know better vadz :( how do you expect CMake to maintain an infinitely growing list of third-party support modules? You (wxWidgets) can contribute to CMake. At least there's a record here of this glaring defect.

Last edited 5 months ago by mick-p1982 (previous) (diff)

comment:7 Changed 5 months ago by vadz

Really, I just don't understand your point. I do understand that you're frustrated, but, again, the file containing the problem is part of CMake distribution. Do you realize that we have absolutely no control over it and can't change it whatever we expect?

comment:8 Changed 5 months ago by mick-p1982

  • Cc holy@… added

Some can edit it here (https://gitlab.kitware.com/cmake/cmake/-/blob/master/Modules/FindwxWidgets.cmake) just like on Github. Someone who understands wxWidget's needs and understands the CMake functionality. This is just commonsense. Is there a better place to report fundamental problems with wxWdigets? This is wxwidgets.org, implying organization. Anyway, I feel like I'm talking to a brick wall.

Last edited 5 months ago by mick-p1982 (previous) (diff)

comment:9 Changed 5 months ago by swt2c

This is not a fundamental problem with wxWidgets, but a problem with a 3rd party build system file, so you report it to the maintainers of the build system. You seem to have a deep misunderstanding about how open source projects work.

Note: See TracTickets for help on using tickets.