Opened 2 months ago

Closed 2 months ago

#18854 closed defect (duplicate)

Restoring dialog size wx3.1.4 Ubuntu 20.04 GTK3

Reported by: rocrail Owned by:
Priority: normal Milestone: 3.1.4
Component: wxGTK Version: dev-latest
Keywords: dialog setsize Cc:
Blocked By: Blocking:
Patch: no

Description

Restoring previous dialog size is no longer possible with v3.1.4 under Ubuntu 20.04 GTK3.
To reproduce the problem you can use the dialog sample and add a line in the OnStandardButtonsSizerDialog function:

void MyFrame::OnStandardButtonsSizerDialog(wxCommandEvent& WXUNUSED(event))
{
    StdButtonSizerDialog  dialog(this);
    dialog.SetSize(10,200,1800,800); // Added for testing setting the Size.
    dialog.ShowModal();
}

Restoring dialog sizes this way under macOS and Windows v3.1.4 is still OK.

https://forums.wxwidgets.org/viewtopic.php?f=23&t=47379

Change History (1)

comment:1 Changed 2 months ago by pcor

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18806

Note: See TracTickets for help on using tickets.