#18466 closed defect (duplicate)

Use of caret crashes app on OSX Mojave 10.14

Reported by: roma_k Owned by:
Priority: normal Milestone: 3.1.3
Component: wxOSX Version: 3.1.2
Keywords: caret mojave 10.14 osx Cc:
Blocked By: Blocking:
Patch: no

Description (last modified by vadz)

Our app crashes when a window with caret shows up.
Sample application 'caret' also crashes when typing/clicking in its window.

wxwidgets 3.1.2 configure:
../configure --with-macosx-version-min=10.10 --with-opengl --enable-shared --disable-monolithic --enable-sockets --enable-unicode --enable-filesystem --enable-fs_inet --enable-debug

Backtrace:

Process:               caret [636]
Path:                  /Users/USER/Documents/*/caret
Identifier:            caret
Version:               0
Code Type:             X86-64 (Native)
Parent Process:        bash [74796]
Responsible:           caret [636]
User ID:               5372

Date/Time:             2019-08-15 11:57:49.854 -0400
OS Version:            Mac OS X 10.14.6 (18G87)
Report Version:        12
Anonymous UUID:        AE0330DE-2A85-74C4-A761-D82BD0B2204B


Time Awake Since Boot: 840000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes:       0x0000000000000001, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Illegal instruction: 4
Termination Reason:    Namespace SIGNAL, Code 0x4
Terminating Process:   exc handler [636]

Application Specific Information:
Detected over-release of a CFTypeRef

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.CoreFoundation      	0x00007fff3f4f0867 _CFRelease + 1075
1   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bcba8d9 wxMacCoreGraphicsContext::SetNativeContext(CGContext*) + 233 (graphics.cpp:2168)
2   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bcbaf37 wxMacCoreGraphicsContext::~wxMacCoreGraphicsContext() + 39 (graphics.cpp:1583)
3   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bcbafe5 wxMacCoreGraphicsContext::~wxMacCoreGraphicsContext() + 21 (graphics.cpp:1584)
4   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bcbb009 wxMacCoreGraphicsContext::~wxMacCoreGraphicsContext() + 25 (graphics.cpp:1582)
5   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010be0acea wxGCDCImpl::SetGraphicsContext(wxGraphicsContext*) + 58 (dcgraph.cpp:139)
6   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bd97aab wxOverlayImpl::EndDrawing(wxDC*) + 91 (overlay.mm:156)
7   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bed9117 wxOverlay::EndDrawing(wxDC*) + 39 (overlaycmn.cpp:69)
8   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bed94be wxDCOverlay::~wxDCOverlay() + 46 (overlaycmn.cpp:109)
9   libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bed94e5 wxDCOverlay::~wxDCOverlay() + 21 (overlaycmn.cpp:109)
10  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bce3597 wxCaret::Refresh() + 231 (caret.cpp:271)
11  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bce3045 wxCaret::Blink() + 37 (caret.cpp:226)
12  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bce301a wxCaret::OnTimer() + 42 (caret.cpp:66)
13  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bce2fe9 wxCaretTimer::Notify() + 25 (caret.cpp:59)
14  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bc6206d wxTimerImpl::Notify() + 29 (timer.h:47)
15  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bc6191e wxProcessTimer(__CFRunLoopTimer*, void*) + 94 (timer.cpp:39)
16  com.apple.CoreFoundation      	0x00007fff3f40deb5 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
17  com.apple.CoreFoundation      	0x00007fff3f40da61 __CFRunLoopDoTimer + 864
18  com.apple.CoreFoundation      	0x00007fff3f40d59a __CFRunLoopDoTimers + 330
19  com.apple.CoreFoundation      	0x00007fff3f3eebe4 __CFRunLoopRun + 2141
20  com.apple.CoreFoundation      	0x00007fff3f3ee135 CFRunLoopRunSpecific + 459
21  com.apple.HIToolbox           	0x00007fff3e63f1ab RunCurrentEventLoopInMode + 292
22  com.apple.HIToolbox           	0x00007fff3e63eee5 ReceiveNextEventCommon + 603
23  com.apple.HIToolbox           	0x00007fff3e63ec76 _BlockUntilNextEventMatchingListInModeWithFilter + 64
24  com.apple.AppKit              	0x00007fff3c9d779d _DPSNextEvent + 1135
25  com.apple.AppKit              	0x00007fff3c9d648b -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1361
26  com.apple.AppKit              	0x00007fff3c9d05a8 -[NSApplication run] + 699
27  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bd53cce wxGUIEventLoop::OSXDoRun() + 174 (evtloop.mm:304)
28  libwx_baseu-3.1.2.0.0.dylib   	0x000000010cbb0837 wxCFEventLoop::DoRun() + 39 (evtloop_cf.cpp:331)
29  libwx_baseu-3.1.2.0.0.dylib   	0x000000010ca9fbd5 wxEventLoopBase::Run() + 229 (evtloopcmn.cpp:90)
30  libwx_baseu-3.1.2.0.0.dylib   	0x000000010ca520ed wxAppConsoleBase::MainLoop() + 189 (appbase.cpp:380)
31  libwx_baseu-3.1.2.0.0.dylib   	0x000000010ca51b49 wxAppConsoleBase::OnRun() + 25 (appbase.cpp:301)
32  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bdcfbcb wxAppBase::OnRun() + 59 (appcmn.cpp:335)
33  libwx_osx_cocoau_core-3.1.2.0.0.dylib	0x000000010bca8549 wxApp::OnRun() + 41 (app.cpp:366)
34  libwx_baseu-3.1.2.0.0.dylib   	0x000000010caecead wxEntry(int&, wchar_t**) + 301 (init.cpp:507)
35  libwx_baseu-3.1.2.0.0.dylib   	0x000000010caed09c wxEntry(int&, char**) + 60 (init.cpp:519)
36  caret                         	0x000000010bbbf613 main + 35 (caret.cpp:172)
37  libdyld.dylib                 	0x00007fff6b3de3d5 start + 1

Change History (3)

comment:1 Changed 12 months ago by vadz

  • Description modified (diff)

comment:2 Changed 12 months ago by vadz

  • Milestone set to 3.1.3

I'll try to debug this, as this seems pretty bad, but any help would be very welcome, as usual with macOS stuff.

comment:3 Changed 11 months ago by vadz

  • Resolution set to duplicate
  • Status changed from new to closed

I'm all but sure this is a duplicate of #18399, as wxCaret uses wxOverlay under macOS.

Note: See TracTickets for help on using tickets.