Opened 4 months ago

Closed 4 months ago

Last modified 3 months ago

#18465 closed defect (fixed)

Code that uses wxPropertyGrid may fail to compile since eca1e857fe

Reported by: dghart Owned by:
Priority: normal Milestone: 3.1.3
Component: wxPropertyGrid Version: dev-latest
Keywords: wxPropertyGrid regression Cc: dghart@…
Blocked By: Blocking:
Patch: no

Description

A CodeLite cpp file will no longer compile against wx3.1.3: wxPropertyGrid is undefined despite #including wx/propgrid/propgrid.h.
It is due to [eca1e857fe] removing the line:
#include "wx/defs.h"
but still doing:
#if wxUSE_PROPGRID

This cannot be seen in the propgrid sample which, like the other wx samples, starts by #including wx/wx.h which loads wx/defs.h.
Presumably other wx headers also include wx/defs directly or indirectly, so user code may fail to compile depending on the order of their wx #includes.

Eight other header files had wx/defs.h removed by [eca1e857fe]. I don't know if all of these changes should be reverted too.

Change History (5)

comment:1 Changed 4 months ago by Paul Cornett <paulcor@…>

In b200c661/git-wxWidgets:

Fix wxPropertyGrid headers so they can be compiled independently

See #18465

comment:2 Changed 4 months ago by vadz

  • Resolution set to fixed
  • Status changed from new to closed

It looks like this was fixed in b200c661edea9332950367a83c9074b217ce2197, so tentatively closing it, please reopen if I'm missing something here.

comment:3 Changed 4 months ago by dghart

  • Cc dghart@… added

Yes, I confirm that Paul's commit fixed the problem.

comment:4 Changed 3 months ago by Paul Cornett <paulcor@…>

In b200c661/git-wxWidgets:

Fix wxPropertyGrid headers so they can be compiled independently

See #18465

comment:5 Changed 3 months ago by Paul Cornett <paulcor@…>

In b200c661/git-wxWidgets:

Fix wxPropertyGrid headers so they can be compiled independently

See #18465

Note: See TracTickets for help on using tickets.