Opened 7 years ago

Closed 7 years ago

#15500 closed build error (fixed)

Current SVN [74819] doesn't build with VS2005

Reported by: ericj Owned by:
Priority: normal Milestone:
Component: build Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

Current SVN [74819] breaks compilation with VS2005.

All errors are caused by msw/dbghelp.h. I don't know if this code is supposed to work with VS2005, but as a quick fix for me, i changed the

#if API_VERSION_NUMBER >= 9
to
#if API_VERSION_NUMBER >= 10

so it doesn't get used with VS2005.

Example errors (191 in total):

c:\SVN\wxWidgets\include\wx/msw/debughlp.h(220) : error C2059: syntax error : '<L_TYPE_raw>'
c:\SVN\wxWidgets\include\wx/msw/debughlp.h(220) : error C2238: unexpected token(s) preceding ';'
c:\SVN\wxWidgets\include\wx/msw/debughlp.h(228) : error C2061: syntax error : identifier 'PENUMLOADED_MODULES_CALLBACKW64'
c:\SVN\wxWidgets\include\wx/msw/debughlp.h(230) : error C2061: syntax error : identifier 'PSYMBOL_INFOW'
c:\SVN\wxWidgets\include\wx/msw/debughlp.h(231) : error C2061: syntax error : identifier 'PIMAGEHLP_LINEW64'
c:\SVN\wxWidgets\include\wx/msw/debughlp.h(232) : error C2061: syntax error : identifier 'PSYM_ENUMERATESYMBOLS_CALLBACKW'
c:\SVN\wxWidgets\include\wx/msw/debughlp.h(300) : error C2146: syntax error : missing ';' before identifier 'SymGetLineFromAddrW64'

Static build, 32bit mode.

Change History (1)

comment:1 Changed 7 years ago by VZ

  • Resolution set to fixed
  • Status changed from new to closed

(In [74820]) Revert "Make wxMSW stack walking methods work with Unicode identifiers."

This reverts r74817 because it broke compilation with VC8 and it doesn't seem
obvious to fix this.

See #15138, closes #15500.

Note: See TracTickets for help on using tickets.