Opened 6 years ago

Last modified 6 years ago

#9974 reopened enhancement

invalid doc references to wrapped C++ classes

Reported by: techtonik Owned by: robind
Priority: normal Milestone:
Component: wxPython Version: oldstable-latest
Keywords: Cc:
Blocked By: #10147 Blocking:
Patch: yes

Description

xrc.py docstrings reference C++ classes without wx prefix

Attachments (2)

xrc.cpp_names.patch download (7.5 KB) - added by techtonik 6 years ago.
patch
python.docstring.patch download (599 bytes) - added by techtonik 6 years ago.
swig.class.docstring.patch

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by techtonik

patch

comment:1 Changed 6 years ago by techtonik

  • Version set to 2.8-svn

comment:2 Changed 6 years ago by robind

  • Owner set to robind
  • Status changed from new to accepted

comment:3 Changed 6 years ago by robind

  • Resolution set to wontfix
  • Status changed from accepted to closed

These strings are automatically generated, so it won't do any good to change them as SWIG will just change them back the next time the file is generated.

comment:4 Changed 6 years ago by techtonik

  • Resolution wontfix deleted
  • Status changed from closed to reopened

The problem is in wxPython-specific patches for SWIG that add custom docstring handling:
source:wxPython/branches/WX_2_8_BRANCH/SWIG

More specifically in swig-1.3.29 patch that adds "wx" names stripping.
source:wxPython/branches/WX_2_8_BRANCH/SWIG/README.txt#L41

Changed 6 years ago by techtonik

swig.class.docstring.patch

comment:5 Changed 6 years ago by techtonik

  • Summary changed from invalid xrc.py doc references to wrapped C++ classes to invalid doc references to wrapped C++ classes

Reworked a patch for SWIG using SVN version.

comment:7 Changed 6 years ago by techtonik

Fixed in SWIG 1.3.37

comment:8 Changed 6 years ago by techtonik

  • Blocked By 10147 added
Note: See TracTickets for help on using tickets.