Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#9744 closed defect (fixed)

graphics.cpp compile error

Reported by: nurf Owned by:
Priority: normal Milestone: 2.9.0
Component: wxMSW Version: stable-latest
Keywords: GDI+ GDIPlus Cc:
Blocked By: Blocking:
Patch: yes

Description

Build-System :

mingw32, gcc 3.4.5-r3
wxWidgets 2.9-Trunk - r54644
GDI+-Build enabled
grapics.cpp - r54234

graphics.cpp failed to compile at line 1529
wxWindowDC is only known as struct at this context, so "dc.GetImpl()" fails

Solution:

Add #include "wx/msw/dcclient.h"

Attachments (1)

graphics.cpp download (51.9 KB) - added by nurf 12 years ago.
grapics.cpp fixed

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by nurf

grapics.cpp fixed

comment:1 Changed 12 years ago by nurf

  • Keywords GDIPlus added
  • Patch set

comment:2 Changed 12 years ago by vadz

  • Status changed from new to infoneeded_new

Could you please give the exact error message? If it's really about wxWindowDC, then including wx/dcclient.h should be enough, no need to include wx/msw/dcclient.h.

Also, if you make another patch please, please read HowToSubmitPatches for how to make a real patch. In particular attaching the entire file is really not the way to do it.

TIA!

comment:3 follow-up: Changed 12 years ago by csomor

  • Resolution set to fixed
  • Status changed from infoneeded_new to closed

with precomp headers VS compiles fine, I think in the non precomp case it may fail because "wx/dcclient.h" (NOT "wx/msw/dcclient", that would be too much) is not included

fixed in r54661, could you please verify

Thanks,

Stefan

comment:4 in reply to: ↑ 3 Changed 12 years ago by nurf

fixed in r54661, could you please verify

confirmed

Note: See TracTickets for help on using tickets.