Opened 6 years ago

Closed 6 years ago

#9585 closed defect (fixed)

[wxOS2]2.8, crash executing cppunit tests

Reported by: dwparsons Owned by:
Priority: normal Milestone:
Component: wxOS2 Version: oldstable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: yes

Description

Currently it is not possible to complete the cppunit test suite with
GCC 3.3.5 (not tested yet with OpenWatcom) due to a crash executing
the CrtTestCase.

The problem is passing a NULL to setenv() in src/os2/utils.cpp
wxSetEnv() when attempting a wxUnsetEnv().

This patch against 2.8 trunk corrects the problem.
Note: 2,9 trunk has the same problem, but the code has changed and
this patch must not be applied there directly.

Attachments (1)

utils_cpp.diff download (808 bytes) - added by dwparsons 6 years ago.
patch to src/os2/utils.cpp

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by dwparsons

patch to src/os2/utils.cpp

comment:1 Changed 6 years ago by vadz

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, applied as r54228.

Note: See TracTickets for help on using tickets.