Opened 7 years ago

Closed 7 years ago

#9543 closed defect (fixed)

listctrl sample: no edit menu

Reported by: troelsk Owned by:
Priority: normal Milestone:
Component: samples Version:
Keywords: wxListCtrl wxMenu Cc:
Blocked By: Blocking:
Patch: yes

Description

If you rightclick the text while editing, you expect to see the edit menu.
Currently you don't.

Patch:

  • samples/listctrl/listtest.cpp fix for trunk
  • samples/listctrl/listtest.cpp fix for 2.8

Notes:

  • Enable the edit menu while editing
  • The patch works as intended on Windows.

On GTK it at least improves things slightly (still no edit menu but at least you don't get the About/Exit context menu which is irrelevant while editing).

Attachments (2)

samples.listctrl.editmenu.2.8.patch download (1.3 KB) - added by troelsk 7 years ago.
2.8
samples.listctrl.editmenu.patch download (1.2 KB) - added by troelsk 7 years ago.
Trunk

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by troelsk

2.8

Changed 7 years ago by troelsk

Trunk

comment:1 Changed 7 years ago by vadz

  • Resolution set to fixed
  • Status changed from new to closed

I don't think this is important enough for 2.8 but applied to trunk, thanks!

Note: See TracTickets for help on using tickets.