Opened 6 years ago

Closed 6 years ago

#9084 closed enhancement (fixed)

wxCocoa wxListBox improvements

Reported by: markdtaylor Owned by: dfe
Priority: normal Milestone:
Component: Old wxCocoa port Version:
Keywords: Cc: markdtaylor, dfe, vadz
Blocked By: Blocking:
Patch: yes

Description

By default, wxListBox entries should not be editable, so we are now explicitly disabling them.

We are now enabling the use of wxLB_HSCROLL and wxLB_ALWAYS_SB to dictate whether horizontal and vertical scrollers, respectively, are shown.

Due to the lack of an auto-hide feature before OS 10.3, wxLB_NEEDED_SB now causes a vertical scroller to always be shown on those OS versions. On OS 10.3 and above, auto-hiding is possible, but cannot be set independently for the horizontal and vertical scrollers. Since there is no equivalent of wxLB_NEEDED_SB for the horizontal scroller, we now assume that auto-hiding should be the default for the horizontal scroller, but in order to allow wxLB_ALWAYS_SB to disable auto-hiding for the vertical scroller, we also disable auto-hiding for the horizontal scroller if wxLB_ALWAYS_SB is set.

Attachments (1)

wxListBox_Fix.txt download (2.2 KB) - added by markdtaylor 6 years ago.
Changes to src/cocoa/listbox.mm r52465 for wxListBox improvements

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by markdtaylor

Changes to src/cocoa/listbox.mm r52465 for wxListBox improvements

comment:1 Changed 6 years ago by wxsite

  • Status changed from assigned to confirmed

transitioning old 'assigned' status to new 'confirmed' status

comment:2 Changed 6 years ago by wojdyr

  • Type set to enhancement

comment:3 Changed 6 years ago by vadz

  • Resolution set to fixed
  • Status changed from confirmed to closed

Thanks, applied as r54322.

P.S. Could you please use .patch or .diff extensions for your patches? Otherwise Trac doesn't recognize them as patches and doesn't show them with nice highlighting. TIA!

Note: See TracTickets for help on using tickets.