Opened 11 years ago

Closed 10 years ago

#4809 closed defect (fixed)

GTK warning after updating GTK to 2.12.9

Reported by: roee88 Owned by:
Priority: high Milestone:
Component: wxGTK Version: 2.8.7
Keywords: wxListCtrl Cc: roee88, vaclavslavik, leio
Blocked By: Blocking:
Patch: no

Description

After updating to gtk 2.12.9 this warning appears when running a wx application:

Gtk-WARNING : gtkwidget.c:8547: widget class GtkPizza' has no property named row-ending-details'

The side effect is notebook tabs not updating correctly.

OS: linux slackware 12.1
wxPython: 2.8.7.1
GTK: 2.12.9

Change History (7)

comment:1 Changed 11 years ago by vaclavslavik

Note: not when running e.g. Poedit on Gentoo (with these exact wx and gtk version)... Can you be more specific in what it takes to reproduce this?

comment:2 Changed 11 years ago by leio

These are really from gtk-engines-2.14.x, and the clearlooks theme engine in particular. It does some cool rounding stuff for some stuff and needs to know from GtkTreeView the row-ending-details, a property which our fake GtkTreeView class doesn't have yet.
I experience the same warnings, coupled with some serious misrenderings, in wxListCtrl focus rectangles in icon view.

comment:3 Changed 10 years ago by wojdyr

  • Keywords wxListCtrl added
  • Priority changed from normal to high
  • Version set to 2.8.7

comment:4 Changed 10 years ago by wojdyr

  • Status changed from new to confirmed

comment:5 Changed 10 years ago by vadz

I'm confused: the OP speaks about wxNotebook, but leio mentions wxListCtrl. These classes don't share any code AFAICS. For the latter I'd guess the problem is in wxRendererGTK::DrawHeaderButton() but I have no idea about the former.

Does anybody have more precise information about this, e.g. how exactly to reproduce it?

comment:6 Changed 10 years ago by roee88

I'm confused: the OP speaks about wxNotebook, but leio mentions wxListCtrl.

The report I got from one of my users was "notebook tabs not updating correctly" but it is possible that the source of the problem is actually wxListCtrl as the notebook contains lists in several pages (in LC_REPORT mode however).

comment:7 Changed 10 years ago by pcor

  • Resolution set to fixed
  • Status changed from confirmed to closed

This is easily reproduced with the listctrl or treectrl samples using GTK+ 2.12 and the Clearlooks theme. The problem is that wxRendererGTK::DrawItemSelectionRect() is calling gtk_paint_focus() with a detail of "treeview" and a widget that is not a GtkTreeView at all. Passing a detail of NULL fixes the warning, and also some drawing glitches with the focus rect. Fixed in r54792.

Note: See TracTickets for help on using tickets.