Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4317 closed defect (fixed)

Unicode and GetTextUTF8()

Reported by: aeonazure Owned by: robind
Priority: normal Milestone:
Component: wxStyledText Version:
Keywords: Cc: aeonazure, robind
Blocked By: Blocking:
Patch: no

Description (last modified by wxsite)

STC.GetTextUTF8() does not return the last character in the control.

This appears to be true historically -- bug is in 2.6.1.0 and 2.8.4.0.

STC.SetText(u'something')
STC.GetText(u'something') -> u'something'
STC.GetTextUTF8(u'something') -> u'somethin'

Change History (3)

comment:1 Changed 7 years ago by wxsite

  • Status changed from assigned to confirmed

transitioning old 'assigned' status to new 'confirmed' status

comment:2 Changed 7 years ago by vadz

  • Resolution set to fixed
  • Status changed from confirmed to closed

Fixed in trunk in r54231, thanks. I am not sure if this should be fixed in 2.8 because I'd probably have inserted a workaround adding the last character manually when using this function in my code and so you can imagine that fixing it now would break code relying on this workaround...

comment:3 Changed 7 years ago by wxsite

  • Description modified (diff)

Actually I already have this same fix made in my 2.8 workspace, just not checked in yet. I think that it should be done in 2.8 too as there isn't really a simple way to workaround this so I don't think anybody has been doing it.

Note: See TracTickets for help on using tickets.