Opened 8 years ago

Closed 22 months ago

#3573 closed defect (fixed)

[Mac] Problems calling .Skip on a wx.EVT_MENU event

Reported by: finell Owned by:
Priority: normal Milestone:
Component: wxOSX-Carbon Version:
Keywords: Cc: finell, csomor
Blocked By: Blocking:
Patch: no

Description

When calling event.Skip in the event callback of a
wx.EVT_MENU event will cause the same event to be fired
again.

This is reproducable in eg. the Menu demo of wxPython.
Ie. calling 'event.Skip' in the Menu101 method will
cause multiple 'Welcome to Mercury' lines to appear in
the log.

I've only tested this on my Mac running the latest
wxPython 2.7.1.2 (unicode build on Python 2.4).

Change History (4)

comment:1 Changed 8 years ago by csomor

yes, this is due to the use of native command ids, OSX tries everything to find a reasonable event handler. Does this pose a problem in your application ?

Thanks,

Stefan

comment:2 Changed 8 years ago by finell

It's as long as you know of the side-effects of course easy
to avoid the problems by simply not calling .Skip ;). Though
this has not been the case before (for older wx versions),
that's why this bit me now when testing the new 2.7 release.

comment:3 Changed 22 months ago by oneeyeman

Adding "event.Skip()" to the !MyFrame::OnAppendMenu() of the menu sample and running it from Cocoa build under 10.6 SDK produce only one message.

I guess it can be closed unless my test is incorrect.

comment:4 Changed 22 months ago by vadz

  • Cc vadz removed
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.