Opened 8 years ago

Closed 20 months ago

#3553 closed defect (fixed)

OSX Removing all pages from notebook does not erase properly

Reported by: alanshouls Owned by:
Priority: normal Milestone:
Component: wxOSX-Carbon Version:
Keywords: Cc: alanshouls, csomor, hockkn
Blocked By: Blocking:
Patch: no

Description

This is a minor bug – if you remove all the pages from a notebook then
it does not erase properly.

  1. Open the ‘widgets’ sample
  2. Select “Notebook” in the left-hand list
  3. In the right-hand area click on the “Add Page” button
  4. Now click on the “Delete All” button
  5. >> There is some debris from the control left on screen (see

attached screen shot)

Attachments (1)

Picture 11.pdf download (4.8 KB) - added by alanshouls 8 years ago.
Debris from Erase

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by alanshouls

Debris from Erase

comment:1 Changed 8 years ago by csomor

is this under 10.3 or 10.4 ? I cannot reproduce unter 10.4.8 intel

Thanks,

Stefan

comment:2 Changed 21 months ago by oneeyeman

The bug itself should probably be closed per Stefan testing.

But I can't re-test as the widgets sample is crashing for me...

comment:3 Changed 21 months ago by oneeyeman

And the notebook sample does not have "Delete ALL" menu...

comment:4 Changed 21 months ago by vadz

This can be tested in the notebook sample.

comment:5 Changed 20 months ago by oneeyeman

This is no longer happening. No more debris.

Tested under 10.6 Cocoa build.

Can be closed.

comment:6 Changed 20 months ago by vadz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.