Opened 8 years ago

Closed 2 years ago

#3544 closed defect (fixed)

OSX Drawing differs in 2.7.1 from 2.6.3

Reported by: alanshouls Owned by: csomor
Priority: normal Milestone:
Component: wxOSX-Carbon Version:
Keywords: Cc: alanshouls, csomor, robind
Blocked By: Blocking:
Patch: no

Description

  1. run osx-build of drawing
  2. >>the ticks don’t have the same apperance as under 2.6.3 (see

attached screen shot), also the circle (top-left) is very different

The anti-aliasing looks just brilliant =;-)

Attachments (3)

Picture 7.pdf download (11.6 KB) - added by alanshouls 8 years ago.
Drawing under 2.7.1
Picture 8.pdf download (6.0 KB) - added by alanshouls 8 years ago.
Drawing under 2.6.3
Picture 9.pdf download (64.5 KB) - added by alanshouls 8 years ago.
grid sample 2.7.1 & 2.6.3

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by alanshouls

Drawing under 2.7.1

Changed 8 years ago by alanshouls

Drawing under 2.6.3

Changed 8 years ago by alanshouls

grid sample 2.7.1 & 2.6.3

comment:1 Changed 8 years ago by alanshouls

There is also a problem in the grid sample. It looks like the same problem
with circles/ovals. I attach a single screenshot of both 2.7.1 and 2.6.3 that
shows the difference - look for the green oval.

comment:2 Changed 8 years ago by csomor

yes both have the same reason, in the end drawn as an
ellipsis, scaled, so the pen gets too big, already solved
if you switch on the Graphic Context Drawing via Command-Y
in the drawing sample

comment:3 Changed 7 years ago by wxsite

  • Status changed from assigned to confirmed

transitioning old 'assigned' status to new 'confirmed' status

comment:4 Changed 2 years ago by oneeyeman

According to Stefan this bug has been closed. It simply was not confirmed.

Does it needs to be rechecked?

comment:5 Changed 2 years ago by vadz

  • Resolution set to fixed
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.