Opened 9 years ago

Closed 22 months ago

#2932 closed defect (outdated)

Click in selection for infinite loop

Reported by: tarkawebfoot Owned by: csomor
Priority: normal Milestone:
Component: wxPython Version:
Keywords: wxOSX Cc: tarkawebfoot, csomor
Blocked By: Blocking:
Patch: no

Description

Using SPE on Mac OS/X, select a block of text, click in the block.
wxMac goes into an infinite loop. Program must be shut down with
Force Quit.

More info from Stani:

On 11/23/05, SPE Stani's Python Editor <spe.stani.be@…>
wrote:
This is a wxMac bug, as it is reproducable on the wxPython Demo
StyledTextControl. The bug is even worse:
1) Select a block of text
2) Single click inside the selection block
You don't need even step 3! Please post this at the wxMac/wxPython
Mailing list.
Stani

On 11/23/05, Brian Myers < tarkawebfoot@…> wrote:
_
http://pythonide.stani.be
http://pythonide.stani.be/manual/html/manual.html
http://pythonide.stani.be/blog/sm_donate
_
Hey, I'm trying to post a bug and the bug tracker won't let me log
on. I shouldn't need to create a new, separate account for this; I
should be able to use this account, shouldn't I?

The bug, BTW, is

1) Select a block of text
2) Single click inside the selection block
3) Single click outside the selection block

SPE goes into an infinite loop and must be killed with Force Quit.

This actually looks more like a wxWindows bug. Let me know if I
should or should not post this.

Brian

Change History (7)

comment:1 Changed 9 years ago by tarkawebfoot

BTW: I'm using wxPython 2.6.1_0.

comment:2 Changed 9 years ago by csomor

Hi

I'd be grateful for any stack traces, or other ideas from
people with wxPython knowledge, because the stc C++ sample
runs without a problem on mac in this situation, and
happily displays the drag outline which can then be
dropped on another application. So it probably is
something in handling the drag event.

Thanks,

Stefan

comment:3 Changed 9 years ago by tarkawebfoot

Hi again,

Sorry, the code goes into an infinite loop, so there is no stack trace. I'm not a
wxPython guru, I just discovered the bug. You might ask Stani or post on the
SPE dev list for some help.

comment:4 Changed 6 years ago by wxsite

  • Status changed from assigned to confirmed

transitioning old 'assigned' status to new 'confirmed' status

comment:5 Changed 2 years ago by oneeyeman

  • Component changed from wxOSX-Carbon to wxPython
  • Keywords wxOSX added

comment:6 Changed 22 months ago by oneeyeman

This ticket is no longer stands.
Running "StyledTextCtrl_1" demo on WinXP SP2, python 2.6, wxPython 2.9.4, selecting the text and then clicking inside the text does not produce the infinite loop.

Can be closed.

comment:7 Changed 22 months ago by robind

  • Resolution set to outdated
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.