Opened 9 years ago

Closed 4 months ago

#2570 closed defect (fixed)

bus error with GetBestVirtualSize()

Reported by: pitrou Owned by: csomor
Priority: normal Milestone:
Component: wxOSX (any toolkit) Version:
Keywords: Cc: pitrou, csomor, hockkn
Blocked By: Blocking:
Patch: no

Description

I have error a bus error on MacOSX when doing a
GetBestVirtualSize() on a wx.MenuBar generated by
xrced. See attached error dump. GetBestVirtualSize() on
other objects seem fine. Other platforms are ok.

This is with Python 2.4.1 and wxPython 2.6.0.1.

Attachments (1)

macosx_dump.txt download (19.7 KB) - added by pitrou 9 years ago.
error dump

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by pitrou

error dump

comment:1 Changed 9 years ago by hockkn

I can't say I'm all that suprised, because a MenuBar on OS X
has a fixed size. Does it do this when the wxMenuBar is not
generated by xrced?

comment:2 Changed 7 years ago by wxsite

  • Status changed from assigned to confirmed

transitioning old 'assigned' status to new 'confirmed' status

comment:3 Changed 2 years ago by oneeyeman

Does this report make any sense?

There is a standard menu bar on OSX and it does not make much sense to change the size on it do something with the size/position with the menu on Mac OSX.

The sizing functions for Mac OSX should give an assert.

This probably should be changed accordingly.

comment:4 Changed 4 months ago by oneeyeman

Should we just generate an assert when the menu bar changes size on OSX? With the text like: "changing size of the menu bar is not supported on Mac".

comment:5 Changed 4 months ago by oneeyeman

  • Component changed from wxOSX-Carbon to wxOSX (any toolkit)

comment:6 Changed 4 months ago by vadz

The point of this bug is that calling wxMenuBar::GetSize() on OS X used to crash. If this is still the case, we must fix it. It doesn't matter that much what does the method -- if it could return the actual menu bar height, it would be better, of course, but if it returned wxDefaultSize it would still be better than crashing.

comment:7 Changed 4 months ago by csomor

I'll do that now

comment:8 Changed 4 months ago by SC

  • Resolution set to fixed
  • Status changed from confirmed to closed

In 76943:

supporting menu dimension retrieval for menubars, fixes #2570

Note: See TracTickets for help on using tickets.