Opened 10 years ago

Closed 6 years ago

#2481 closed defect (outdated)

TIFF compression default is rejected

Reported by: ni1d Owned by:
Priority: normal Milestone:
Component: GUI-all Version:
Keywords: wxImage tiff LZW Cc: ni1d, nerijus
Blocked By: Blocking:
Patch: no

Description

On Linux/GTK at least, the default compression (LZW) is
rejected by libtiff due to patent issues.

It would be good to pick a different default, perhaps
PACKBITS, that is not encumbered. It would also help
if the way to choose another compression algorithm were
documented

Change History (4)

comment:1 Changed 10 years ago by nerijus

Hasn't this patent expired a few years ago?

comment:2 Changed 10 years ago by ni1d

That's not what I read on
http://www.gnu.org/philosophy/gif.html. You may be right
about the USA patent, but the implication is that there are
others.

comment:3 Changed 7 years ago by wojdyr

  • Component set to GUI-all
  • Keywords tiff LZW added

comment:4 Changed 6 years ago by wojdyr

  • Resolution set to outdated
  • Status changed from new to closed

I had a look at libtiff ChangeLog. LZW compression code was merged back before 3.7.0 and wx is distributed with 3.8.2, so I suppose the problem is gone.

Note: See TracTickets for help on using tickets.