Opened 3 years ago

Closed 3 months ago

#17871 closed defect (fixed)

[MSW] wxRichTooltip crash/assert

Reported by: ericj Owned by:
Priority: normal Milestone:
Component: wxMSW Version: dev-latest
Keywords: wxRichTooltip Cc:
Blocked By: Blocking:
Patch: no

Description

Using wxRichTooltip can create an "recursive ReleaseMouse call?" assert in wxWindowBase::ReleaseMouse under certain conditions.

It can be seen in the unmodified "dialogs" sample:

  • start "dialogs" sample
  • open wxRichTooltip dialog by pressing ctrl-h
  • set timeout to 3 seconds
  • check "delay show"
  • click on "show for button" so that the mouse cursor is at the right end of the button (important is that the mouse will be inside the area of the tooltip when it appears)
  • keep clicking while keeping the mouse at the same position, the assert will occur when the timeout is reached and the tooltip disappears

I don't know if this is MSW specific or not, i tested under MSW only.

Attachments (1)

richtooltip_overlap.png download (14.5 KB) - added by ericj 3 years ago.
show relative position of button that initiates tooltip, tooltip itself and mouse pointer position

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by ericj

show relative position of button that initiates tooltip, tooltip itself and mouse pointer position

comment:1 Changed 3 months ago by vadz

  • Resolution set to fixed
  • Status changed from new to closed

I think this has been fixed as a side effect of all the wxPopupWindow-related changes, at least I can't reproduce it any longer -- maybe because clicking the mouse dismisses the tooltip immediately. Please reopen if you still see this.

Note: See TracTickets for help on using tickets.