Opened 5 years ago

Closed 4 years ago

#16924 closed defect (fixed)

problem in running demo with Python 2.7.

Reported by: masoud Owned by:
Priority: normal Milestone: 3.0.3
Component: wxPython Version: 3.0.2
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

I have just installed python 2.7.9 and wxpthon wxPython3.0-win64-3.0.2.0-py27.exe. The demo PyPlot.py available in "wxPython3.0 Docs and Demos" is no longer working and gives this error message. I tried with win32 version, the error persists.
Thanks
Masoud

G:\python "G:\wxPython3.0 Docs and Demos\demo\PyPlot.py"
Python 2.7.9 (default, Dec 10 2014, 12:28:03) [MSC v.1500 64 bit (AMD64)]
wx.version: 3.0.2.0 msw (classic)
Traceback (most recent call last):

File "G:\wxPython3.0 Docs and Demos\demo\PyPlot.py", line 34, in OnButton

win = wx.lib.plot.TestFrame(self, -1, "PlotCanvas Demo")

File "G:\python64\lib\site-packages\wx-3.0-msw\wx\lib\plot.py", line 2309, in init

self.client = PlotCanvas(self)

File "G:\python64\lib\site-packages\wx-3.0-msw\wx\lib\plot.py", line 598, in init

self.HandCursor = wx.Cursor(Hand.GetImage())

File "G:\python64\lib\site-packages\wx-3.0-msw\wx\_gdi.py", line 1547, in init

_gdi_.Cursor_swiginit(self,_gdi_.new_Cursor(*args, kwargs))

TypeError: Required argument 'type' (pos 2) not found

Attachments (1)

plot.py download (97.7 KB) - added by masoud 4 years ago.
correction in the plot.py

Download all attachments as: .zip

Change History (4)

comment:1 Changed 4 years ago by masoud

Hello,
any news about this bug? has anybody seen this ticket?
Thanks,
Masoud

Changed 4 years ago by masoud

correction in the plot.py

comment:2 Changed 4 years ago by thorr18

  • Status changed from new to confirmed

This was already corrected in [30bc07d8] (March 2015) (changeset:30bc07d80ae1c81d70b4de2daac62ecd7996d703)

I'm having trouble with traclinks, so I'll just link to it

here:
https://github.com/wxWidgets/wxPython/commit/30bc07d80ae1c81d70b4de2daac62ecd7996d703
or here:
http://trac.wxwidgets.org/browser/git-wxPython/?rev=30bc07d80ae1c81d70b4de2daac62ecd7996d703

This is a duplicate issue of issue #16767
The issue is in the 3.0.2 release, but not in 3.0.3 source.
I tested it on 3.0.2 & 3.0.3 to confirm.

comment:3 Changed 4 years ago by thorr18

  • Milestone set to 3.0.3
  • Priority changed from high to normal
  • Resolution set to fixed
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.