Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16823 closed defect (fixed)

wxAboutBox - GtkDialog mapped without a transient parent - GTK3

Reported by: swt2c Owned by: PC
Priority: normal Milestone:
Component: wxGTK Version: 3.0.2
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

When a wxAboutBox is created, this message is logged:
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

Not sure what this means. The dialog appearance seems to be OK as best as I can tell.

Can be reproduced with samples/dialogs and Help->About (simple/fancy/full).

Change History (3)

comment:1 Changed 5 years ago by PC

  • Owner set to PC
  • Resolution set to fixed
  • Status changed from new to closed

In 78433/svn-wx:

set transient parent for 'about' dialog, closes #16823

comment:2 Changed 5 years ago by Paul Cornett <paulcor@…>

In bb3dcf85fb05324a4fb71769635a820661c82797/git-wxWidgets:

set transient parent for 'about' dialog, closes #16823

git-svn-id: https://svn.wxwidgets.org/svn/wx/wxWidgets/branches/WX_3_0_BRANCH@78433 c3d73ce0-8a6f-49c7-b76d-6d57e0e08775

comment:3 Changed 5 years ago by Paul Cornett <paulcor@…>

In 0c0484eaae5c9499fabde728f0fdc95c5b77a87a/git-wxWidgets:

set transient parent for 'about' dialog, closes #16823

git-svn-id: https://svn.wxwidgets.org/svn/wx/wxWidgets/trunk@78433 c3d73ce0-8a6f-49c7-b76d-6d57e0e08775

Note: See TracTickets for help on using tickets.