Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#16767 closed defect (fixed)

wx.plot.lib broken in classic

Reported by: swt2c Owned by:
Priority: normal Milestone:
Component: wxPython Version: 3.0.2
Keywords: Cc:
Blocked By: Blocking:
Patch: yes

Description

It looks like some Phoenix changes might have been inadvertently picked up in ticket #16590 / changeset 77995, resulting in problems for Classic:

Traceback (most recent call last):

File "test1.py", line 11, in <module>

mainframe = Frame(None)

File "test1.py", line 7, in init

plotPanel = plot.PlotCanvas(self, size=(4.5*96, 3.5*96))

File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/lib/plot.py", line 598, in init

self.HandCursor = wx.Cursor(Hand.GetImage())

File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_gdi.py", line 1510, in init

_gdi_.Cursor_swiginit(self,_gdi_.new_Cursor(*args, kwargs))

TypeError: Required argument 'type' (pos 2) not found

Patch attached to correct.

Attachments (1)

wxPython-3.0.2.0-plot.patch download (4.1 KB) - added by swt2c 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by swt2c

comment:1 Changed 3 years ago by thorr18

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 3 years ago by thorr18

This was corrected in [30bc07d8] (March 2015) (changeset:30bc07d80ae1c81d70b4de2daac62ecd7996d703)
I'm having trouble with traclinks, so I'll just link to it
here:
https://github.com/wxWidgets/wxPython/commit/30bc07d80ae1c81d70b4de2daac62ecd7996d703
or here:
http://trac.wxwidgets.org/browser/git-wxPython/?rev=30bc07d80ae1c81d70b4de2daac62ecd7996d703

Linked to this from newer duplicate issue #16924
The issue is in the 3.0.2 release, but not in 3.0.3 source.
I tested it on 3.0.2 & 3.0.3 to confirm and closed this one.

Note: See TracTickets for help on using tickets.