Opened 6 years ago

Closed 14 months ago

#16591 closed enhancement (fixed)

Strikethrough implementation patch

Reported by: oneeyeman Owned by:
Priority: normal Milestone:
Component: wxRichText Version:
Keywords: font strikethrough Cc: julian@…
Blocked By: Blocking:
Patch: yes

Description

This is hopefully the final patch implementing the strikethrough font feature.
It modifies text control and RichTextCtrl.

The patch was tested with text and richtext samples on Windows.

Attachments (1)

16591.patch download (4.7 KB) - added by oneeyeman 6 years ago.
Implementation patch

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by oneeyeman

Implementation patch

comment:1 Changed 6 years ago by vadz

  • Cc julian@… added
  • Component changed from GUI-all to wxRichText
  • Keywords simple removed
  • Status changed from new to confirmed

Thanks, I'm applying the wxMSW wxTextCtrl part but would like to leave the rest to Julian as I don't know this code at all (all I can see is some strange indentation in the headers and missing documentation for the end method).

comment:2 Changed 6 years ago by VZ

In 78315:

Add support for strikeout fonts to wxMSW wxTextCtrl.

Map them to CFE_STRIKEOUT in the native rich text control.

See #16591.

comment:3 Changed 4 years ago by oneeyeman

Julian,
Could you please check if this patch is still relevant and apply?

Thank you.

comment:4 Changed 14 months ago by oneeyeman

  • Resolution set to fixed
  • Status changed from confirmed to closed

It looks like the wxRichText is already implements support for "Strikethrough" feature.

I just tested the sample on GTK+3 build of wxWidgets and everything works as expected.
The same is true for wxRTC on OSX Cocoa.

I think it is time to close this ticket, since text control on MSW portion was already applied.

Note: See TracTickets for help on using tickets.