Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16590 closed defect (fixed)

Update wxpython lib/plot.py (numpy has removed oldnumeric)

Reported by: ryexander Owned by: robind
Priority: normal Milestone:
Component: wxPython Version:
Keywords: wx.lib.plot Cc:
Blocked By: Blocking:
Patch: yes

Description

Numpy has removed the numpy.oldnumeric module with numpy 1.9

it's high time to update the wx.lib.plot module to use proper numpy anyway

this patch should be applied to the wxPython branch and the Phoenix branch

Attachments (3)

plot.py.patch download (24.2 KB) - added by ryexander 5 years ago.
classic-plot.py.patch download (127.1 KB) - added by ryexander 5 years ago.
classic branch
phoenix-plot.py.patch download (110.0 KB) - added by ryexander 5 years ago.
phoenix branch

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by ryexander

comment:1 Changed 5 years ago by robind

  • Owner set to robind
  • Status changed from new to accepted

This patch does not apply cleanly to the wxPython (classic) version of plot.py, could you please create a new patch with your changes for the wxPython branch? (Add it to this ticket.)

Thanks.

Last edited 5 years ago by robind (previous) (diff)

comment:2 Changed 5 years ago by robind

See also #16425. Looks like there is some overlap between this and that patch that will need to be dealt with.

Changed 5 years ago by ryexander

classic branch

Changed 5 years ago by ryexander

phoenix branch

comment:3 Changed 5 years ago by ryexander

Updated, I merged changes from #16425

their method was to simply import numpy under the old _Numeric global and remap the fed changed type names, while this certainly works as intended I feel that the full name replacement I used is better for future maintenance as there is no confusion over which version of numpy used.

Attached two new patch files one for the classic branch one for Phoenix

comment:4 Changed 5 years ago by ryexander

Updated, I merged changes from #16425

their method was to simply import numpy under the old _Numeric global and remap the fed changed type names, while this certainly works as intended I feel that the full name replacement I used is better for future maintenance as there is no confusion over which version of numpy used.

Attached two new patch files one for the classic branch one for Phoenix

comment:5 Changed 5 years ago by RD

  • Resolution set to fixed
  • Status changed from accepted to closed

In 77995:

Apply patch updating wx.lib.plot, closes #16590

comment:6 Changed 5 years ago by RD

In 78006:

Apply patch updating wx.lib.plot, closes #16590

Note: See TracTickets for help on using tickets.