Opened 8 months ago

Closed 8 months ago

Last modified 7 months ago

#16232 closed defect (fixed)

The wxWindowMac::DoEnable method doesn't update children state

Reported by: Mithrandir Owned by: SC
Priority: normal Milestone:
Component: wxOSX-Cocoa Version: 3.0.0
Keywords: wxWindowMac DoEnable children Enable Mac OS X Cc:
Blocked By: Blocking:
Patch: yes

Description

wxWidgets 3.0 contains issue with the method wxWindow::Enable(bool) and probably Disable() on Mac OS X Cocoa. It does not disable/enable children of a window. To fix this need to propagate changed state to all children of the window.

The patch against trunk is attached.

Attachments (1)

window_osx.cpp.patch download (709 bytes) - added by Mithrandir 8 months ago.
window_osx.cpp.patch

Download all attachments as: .zip

Change History (8)

Changed 8 months ago by Mithrandir

window_osx.cpp.patch

comment:1 Changed 8 months ago by Mithrandir

Mac OS X version 10.8 and 10.9.

comment:2 Changed 8 months ago by csomor

the code to do so is already in the base classes, I'll enable that for osx_cocoa

comment:3 Changed 8 months ago by SC

  • Owner set to SC
  • Resolution set to fixed
  • Status changed from new to closed

In 76468:

using the base class wxHAS_NATIVE_ENABLED_MANAGEMENT in cocoa disabling/enabling child windows, fixes #16232, fixes #15495

comment:4 Changed 8 months ago by csomor

  • Resolution changed from fixed to port to stable
  • Status changed from closed to portneeded

duplicate of #15495

comment:5 Changed 8 months ago by SC

  • Resolution changed from port to stable to fixed
  • Status changed from portneeded to closed

In 76469:

backport, fixing enabling/disabling child windows, closes #16232

comment:6 Changed 7 months ago by SC

In 76565:

(The changeset message doesn't reference this ticket)

comment:7 Changed 7 months ago by csomor

last change entry is wrongly attributed to this ticket, that change belongs to a different ticket #14269

Note: See TracTickets for help on using tickets.