Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#16049 closed defect (fixed)

Tests failed because wxWebSite was changed

Reported by: kosenko Owned by:
Priority: normal Milestone:
Component: samples Version: dev-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

    wxURL url("http://wxwidgets.org/logo9.jpg");
    CPPUNIT_ASSERT_EQUAL(wxURL_NOERR, url.GetError());

    wxInputStream *in_stream = url.GetInputStream();
    CPPUNIT_ASSERT(in_stream && in_stream->IsOk());
./uris/url.cpp:77:Assertion
Test name: URLTestCase::GetInputStream
assertion failed
- Expression: in_stream && in_stream->IsOk()

Web site was changed about a month ago according Travic CI failures but nobody cares. https://api.travis-ci.org/wxWidgets/wxWidgets.png

Change History (2)

comment:1 Changed 6 months ago by VZ

  • Resolution set to fixed
  • Status changed from new to closed

(In [76088]) Update the URL of the web site images used in the test.

The old images don't exist any more after web site redesign.

Also, the new favicon can't be loaded from an unseekable stream because it
contains multiple icons, so point to the old favicon instead.

Closes #16049.

comment:2 Changed 6 months ago by VZ

(In [76089]) Update the URL of the web site images used in the test.

The old images don't exist any more after web site redesign.

Also, the new favicon can't be loaded from an unseekable stream because it
contains multiple icons, so point to the old favicon instead.

Closes #16049.

Note: See TracTickets for help on using tickets.