Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#16002 closed defect (fixed)

wxDD_DIR_MUST_EXIST has no effect in wxGTK.

Reported by: jbbbms Owned by:
Priority: normal Milestone:
Component: wxGTK Version: 3.0.0
Keywords: simple Cc:
Blocked By: Blocking:
Patch: no

Description

At the first, when the dialog appears, there isn't a [Create Folder] button on the top-right corner of the dialog, whether wxDD_DIR_MUST_EXIST or not. After we browse in the dialog to somewhere else, the [Create Folder] button appears. wxDD_DIR_MUST_EXIST can't stop it from showing up.

Thanks. Have a nice day.

Attachments (1)

a.cpp download (417 bytes) - added by jbbbms 7 months ago.
For reconstructing the unexpected behavior.

Download all attachments as: .zip

Change History (4)

Changed 7 months ago by jbbbms

For reconstructing the unexpected behavior.

comment:1 Changed 7 months ago by vadz

  • Keywords simple added
  • Status changed from new to confirmed

It looks like this would be trivial to support with GTK+ 2.18+ using gtk_file_chooser_set_create_folders().

Patches would be welcome.

comment:2 Changed 7 months ago by PC

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [75997]) add support for wxDD_DIR_MUST_EXIST, closes #16002

comment:3 Changed 7 months ago by VZ

(In [76000]) Mention wxDD_DIR_MUST_EXIST support in wxGTK in the change log.

Document the change of r75997, see #16002.

Note: See TracTickets for help on using tickets.