Opened 2 years ago

Closed 9 days ago

#15896 closed defect (fixed)

Problems in samples/widgets with GTK3

Reported by: Hanmac Owned by:
Priority: normal Milestone:
Component: wxGTK Version: dev-latest
Keywords: gtk3 Cc:
Blocked By: Blocking:
Patch: no

Description

wxDatePicker:

  • the layout is broken, i can't see it its only 1 px high (should be connected to wxOwnerDrawnComboBox)
  • wxDP_SPIN is not available in all ports (not in generic), disable the option for it

wxListBox:

  • the Checked box are not visible when the verylong entry is added

wxItemContrainer:

  • the Tests does fail when Sort is enabled

wxOwnerDrawnComboBox:

  • the layout is broken, i can't see it its only 1 px high
  • the "Bitmap Button" does break it with "width >= 0 && height >= 0" failed in Create(): invalid bitmap size

Change History (9)

comment:1 Changed 2 years ago by vadz

  • Status changed from new to infoneeded_new

Which platform are you testing under? I don't see the first problem neither under GTK nor MSW.

comment:2 Changed 2 years ago by Hanmac

  • Status changed from infoneeded_new to new

i tested GTK3, it might be that it does not happen on GTK2

comment:3 Changed 2 years ago by vadz

  • Component changed from samples to wxGTK
  • Keywords gtk3 added
  • Summary changed from samples/widgets is broken at some points (raise asserts) to Problems in samples/widgets with GTK3

We probably should open separate tickets for these problems as they're all or at least mostly GTK3 specific. In fact I think we already have one for wxDatePicker.

comment:4 Changed 2 years ago by PC

(In [75668]) Fix best size calculation with GTK3
GTK3 reports preferred size of hidden widgets as zero.
see #15896

comment:5 follow-up: Changed 2 years ago by Hanmac

after 75668 wxDatePicker & wxOwnerDrawnComboBox are visible again but ...
wxDatePicker cant select any date or change month or year
wxOwnerDrawnComboBox items can only selected with keyboard not with mouse

so the Popup is shown and closed, but nothing cant selected

comment:6 in reply to: ↑ 5 Changed 2 years ago by pcor

wxDatePicker cant select any date or change month or year

This is #15874

comment:7 Changed 9 days ago by Artur Wieczorek <artwik@…>

In 2f4d6f434a5b1c2dcb571c2bc83565e645d5832d/git-wxWidgets:

Sort reference data used in tests in widgets sample in dictionary order.

Contents of controls (like ListBox, Choice, ComboBox) created with wxXX_SORT flag is sorted in dictionary order and therefore reference data items used in tests in widgets sample need to be sorted in this order too.

See #15896.

comment:8 Changed 9 days ago by Artur Wieczorek <artwik@…>

In 9b3367a45f85ff2251db311dde4de6e422cadd9b/git-wxWidgets:

Reset client data flag when wxOwnerDrawnComboBox contents is cleared.

When contents of wxOwnerDrawnComboBox with user data is cleared then client data type should be reset to wxClientData_None value.

See #15896.

comment:9 Changed 9 days ago by awi

  • Resolution set to fixed
  • Status changed from new to closed

I cannot reproduce reported UI issues under Ubuntu 15.10 / GTK+ 3.16.7 with latest wx 3.1 trunk.

I could reproduce this issue with assertion message when test was executed for sorted controls like ListBox, Choice, BitmapComboBox, but not only under wxGTK but for wxMSW as well. This is hopefully fixed by 2f4d6f43.

I found another issue when assertion message was raised for test run for OwnerDrawnCombox regardless of its sorting mode. This is fixed by 9b3367a4.

Please reopen the ticket if you still observe the issues.

Note: See TracTickets for help on using tickets.