Opened 6 months ago

Closed 6 months ago

#15891 closed defect (fixed)

Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

Reported by: kynikos Owned by:
Priority: low Milestone:
Component: wxGTK Version: 3.0.0
Keywords: gtk error layout Cc:
Blocked By: Blocking:
Patch: no

Description

The two tests in the attached script systematically generate the following GTK critical error when calling Layout on my system:

Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed

My system:
Arch Linux x86_64
GTK+ 2.24.22
wxGTK 3.0.0
wxPython 3.0.0.0

Attachments (1)

gtk_error.py download (603 bytes) - added by kynikos 6 months ago.
script for reproducing the error

Download all attachments as: .zip

Change History (3)

Changed 6 months ago by kynikos

script for reproducing the error

comment:1 Changed 6 months ago by vadz

  • Priority changed from normal to low

This is actually probably harmless (in spite of "critical" in the error message) and just indicates that the initial size of something is too small. Of course, it would be nice to still get rid of it...

comment:2 Changed 6 months ago by PC

  • Resolution set to fixed
  • Status changed from new to closed

(In [75688]) fix a couple GTK assertions about setting negative sizes, closes #15891

Note: See TracTickets for help on using tickets.