Opened 7 months ago

Closed 6 months ago

Last modified 6 months ago

#15874 closed defect (fixed)

wxDatePickerCtrl not working correctly on GTK3

Reported by: Thomas_Behn Owned by:
Priority: normal Milestone:
Component: GUI-all Version: 3.0.0
Keywords: wxDatePickerCtrl, wxGTK Cc:
Blocked By: Blocking:
Patch: no

Description

Hi guys,

When I compile my program with wxWidgets 3.0.0 using GTK3, I can not use the wxDatePickerCtrl in a modal dialog acceptably. When I try to select a date, the dropdown box closes, but the date is not selected. I can only select a date by pressing the up/down/left/right arrow keys and space alternately.

There is no problem with wxWidgets 3.0.0 compiled using GTK2 on the same system.

Any ideas or help?

Attachments (1)

mbgprotosim_dat.png download (84.7 KB) - added by Thomas_Behn 6 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 months ago by vadz

Can this be seen in the calendar sample too?

Changed 6 months ago by Thomas_Behn

comment:2 Changed 6 months ago by Thomas_Behn

No. I have just checked that and seen, that everything seems to work fine in the sample.
But there's still the difference, that my wxDatePickerCtrl is placed in a panel of a wxNotebook.
Perhaps a screenshot helps in this case (see attached).

comment:3 Changed 6 months ago by vadz

  • Keywords repro-needed added

A minimal patch against the calendar sample reproducing the problem would be really helpful.

comment:4 Changed 6 months ago by pcor

  • Keywords repro-needed removed
  • Status changed from new to confirmed

Can be seen with the widgets sample. Looks like generic combobox is broken.

comment:5 Changed 6 months ago by Thomas_Behn

So no patch needed, right?
Will use my gtk2 build in the meantime...
Thanks!

comment:6 Changed 6 months ago by PC

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [75687]) fix wxPopupTransientWindow mouse events with GTK3, also fixes wxOwnerDrawnComboBox, wxDatePickerCtrl. closes #15874

comment:7 Changed 6 months ago by Thomas_Behn

Wonderful, thanks. Will this be in wxWidgets 3.0.1?

comment:8 Changed 6 months ago by Hanmac

hm the keyboard does not work inside the wxDatePickerCtrl popup, is that wanted?

Note: See TracTickets for help on using tickets.