#15872 closed defect (fixed)

Wrong wxStaticBox best size computation with some themes in wxGTK

Reported by: GadgetSteve Owned by:
Priority: high Milestone:
Component: wxGTK Version: 3.0.0
Keywords: wxStaticBox gtk Cc:
Blocked By: Blocking:
Patch: no

Description

The default gtk2 build on Linux results in static boxes with the label inside the box rather than on the border as can be seen in the attached screenshots. Both were built from the wxWidgets 3.0.0 source. The right picture was in a build with ../configure --with-gtk=3 rather than ../configure --with-gtk my libgtk versions:

gadget@gadget-Aspire-8935G:~/ToolBuild/wxWidgets-3.0.0$ dpkg -l libgtk[-0-9]*Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)

/ Name Version Architecture Description

+++-===================-==============-==============-============================================
ii libgtk-3-0:amd64 3.8.6-0ubuntu3 amd64 GTK+ graphical user interface library
ii libgtk-3-0-dbg:amd6 3.8.6-0ubuntu3 amd64 GTK+ libraries and debugging symbols
ii libgtk-3-bin 3.8.6-0ubuntu3 amd64 programs for the GTK+ graphical user interfa
ii libgtk-3-common 3.8.6-0ubuntu3 all common files for the GTK+ graphical user int
ii libgtk-3-dev 3.8.6-0ubuntu3 amd64 development files for the GTK+ library
ii libgtk-3-doc 3.8.6-0ubuntu3 all documentation for the GTK+ graphical user in
un libgtk-directfb-2.0 <none> (no description available)
ii libgtk2-perl 2:1.247-2 amd64 Perl interface to the 2.x series of the Gimp
un libgtk2-perl-doc <none> (no description available)
ii libgtk2.0-0:amd64 2.24.20-1ubunt amd64 GTK+ graphical user interface library
rc libgtk2.0-0:i386 2.24.20-1ubunt i386 GTK+ graphical user interface library
ii libgtk2.0-bin 2.24.20-1ubunt amd64 programs for the GTK+ graphical user interfa
ii libgtk2.0-cil 2.12.10-5 amd64 CLI binding for the GTK+ toolkit 2.12
ii libgtk2.0-common 2.24.20-1ubunt all common files for the GTK+ graphical user int
ii libgtk2.0-dev 2.24.20-1ubunt amd64 development files for the GTK+ library
un libgtk2.0-doc <none> (no description available)

Attachments (2)

layout_demo_kde_3_2.png download (80.2 KB) - added by GadgetSteve 11 months ago.
Layout Demo built with --use-gtk=3 (left) verses default gtk2
layout_demo_kde_3_2_Hilight.png download (81.1 KB) - added by GadgetSteve 11 months ago.

Download all attachments as: .zip

Change History (7)

Changed 11 months ago by GadgetSteve

Layout Demo built with --use-gtk=3 (left) verses default gtk2

comment:1 Changed 11 months ago by GadgetSteve

N.B. This was not the case with wxWidgets 2.7

comment:2 Changed 11 months ago by vadz

Isn't this just how this theme works? I.e. does it really look different from other GTK+ (2) applications?

Changed 11 months ago by GadgetSteve

comment:3 Changed 11 months ago by GadgetSteve

As per the attached markup, , the text that was on the border of the StaticBox prior to wx 3.0.0, and still is with gtk 3 and on msw, is inside the box - this spoils the layout and results in a missing bottom line to the box.

comment:4 Changed 11 months ago by vadz

  • Priority changed from normal to high
  • Status changed from new to confirmed
  • Summary changed from wx 3.0.0 Misplaces StaticBox label on gtk2 to Wrong wxStaticBox best size computation with some themes in wxGTK

Yes, the best size computation is wrong in wxStaticBox, see this thread. Unfortunately I still have no idea what to do about it.

This is bad though as you're at least the third person reporting it since 3.0.

comment:5 Changed 11 months ago by PC

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [75696]) fix GetBordersForSizer(), closes #15872

Note: See TracTickets for help on using tickets.