#15564 closed defect (fixed)

Copyright on platform logos?

Reported by: ojwb Owned by:
Priority: normal Milestone: 3.0.0
Component: documentation Version: stable-latest
Keywords: Cc: bpetty
Blocked By: Blocking:
Patch: no

Description

There are logos for some of the platforms wx supports in docs/doxygen/images/ in the sources, which can more easily be seen here:

http://docs.wxwidgets.org/3.0.0/page_port.html

Looking at the VCS history, these were added in r52292 and r55859 by Francesco Montorsi, but there isn't any indication where they actually came from, and those for MSW, OS X, and Motif looks suspiciously like they are probably just taken from the websites of the respective companies (Motif code is now LGPL, but that happened after this logo was added to the wx VCS, and the Motif logo used here doesn't seem to match anything on the current Motif open source site).

I'd like if possible to clarify where they came from and what licences they are under - if they aren't suitably licensed, I can't include them in the Debian package. While you may not agree with Debian's requirements in such matters, it's a problem for wx if they aren't actually legally redistributable, so I'm opening this ticket rather than simply repacking to remove them from what Debian redistributes.

The logos for GTK and X.org are probably under licences which permit redistribution, though it would be good to clarify the situation for these too.

(I'm actually looking at 3.0.0, but that's not an option in the trac version picker).

Change History (3)

comment:1 Changed 12 months ago by bpetty

  • Cc bpetty added
  • Milestone set to 3.0
  • Status changed from new to confirmed

In all honesty, I don't think they are even really necessary here, and you might be right about some of these. I'm going to go ahead and just remove them. OSX logo seems to be broken anyway.

I'm going to leave this ticket open for someone else as a reminder to add the 3.0.0 version to Trac.

comment:2 Changed 12 months ago by BP

(In [74972]) Removed unnecessary 3rd party copyrighted logos from the manual, see #15564.

comment:3 Changed 12 months ago by vadz

  • Resolution set to fixed
  • Status changed from confirmed to closed

I've added 3.0.0-rc1 to the list of versions now.

Note: See TracTickets for help on using tickets.