#15517 closed defect (fixed)

Drop support for obsolete libgnomeprint

Reported by: ojwb Owned by:
Priority: normal Milestone: 3.0.0
Component: printing Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: yes

Description

Currently wx trunk has support for both gtkprint and gnomeprint. If neither are enabled, wx falls back to its built-in postscript printing.

However, gnomeprint has long been deprecated in favour of gtkprint:

https://developer.gnome.org/platform-overview/2.32/printing.html.en#gnomeprint

The gtkprint code was added in GTK+ 2.10, which was released over 7 years ago:

https://mail.gnome.org/archives/gtk-list/2006-July/msg00013.html

At this point, it's a pretty safe bet that everyone using GTK+ will be on >= 2.10 (even RHEL 5.9 seems to have 2.10). If there's really anyone left who isn't, there's still wx's built-in postscript printing. The sort of people who might be clinging to a 7+ year old version of GTK+ are hardly going to be rushing to upgrade to a .0 release of anything either.

So I'd suggest dropping support for libgnomeprint before the wx 3.0 release so it doesn't end up living on for another release cycle.

I've attached a patch against trunk which does this.

Attachments (3)

wx-remove-libgnomeprint-support.patch download (20.3 KB) - added by ojwb 11 months ago.
patch to remove gnomeprint support
wxpython-remove-libgnomeprint-support.patch download (355 bytes) - added by ojwb 11 months ago.
Follow-on patch to tidy up reference to gnomeprint in wxPython
wx-gtk-readme.patch download (827 bytes) - added by ojwb 11 months ago.
patch to update gtk readme to reflect gtkprint

Download all attachments as: .zip

Change History (13)

Changed 11 months ago by ojwb

patch to remove gnomeprint support

Changed 11 months ago by ojwb

Follow-on patch to tidy up reference to gnomeprint in wxPython

comment:1 Changed 11 months ago by vadz

  • Milestone set to 3.0
  • Status changed from new to confirmed

I agree that we should do this, this code (source:wxWidgets/trunk/src/gtk/gnome/gprint.cpp) isn't really maintained anyhow and I don't think we'll find anybody willing to work on it. So if there are no objections I'll do it before 3.0-RC1.

In the future it would be nice to get rid of source:wxWidgets/trunk/src/gtk/gnome/gvfs.cpp too, but we don't have any replacement for it...

comment:2 in reply to: ↑ description Changed 11 months ago by pcor

Replying to ojwb:

The gtkprint code was added in GTK+ 2.10, which was released over 7 years ago:

I don't personally care about libgnomeprint, but we do still support building against GTK+ 2.6.

comment:3 Changed 11 months ago by vadz

Supporting GTK+ 2.6 is not such a bad idea (there are still old systems on which later versions are not very usable) but I am not sure if Gnome printing is really better than our PS printing code. Which is pretty horrible, of course, but OTOH I've never had any good experience with Gnome printing neither. Does anybody at least know if it works at all? Because I wouldn't be terribly surprised if it didn't...

comment:4 follow-up: Changed 11 months ago by ojwb

pcor: I wasn't proposing to drop support for GTK+ < 2.10, only libgnomeprint.

On that thought though, is it time to drop gtk1 support? According to docs/gtk/readme.txt it's not been maintained since 2.8:

wxWidgets 2.8 still supports GTK+ 1.2, but no developement is done on that port anymore and support for GTK+ 1.2 will probably be dropped entirely.

I'm happy to open a new ticket and prepare a patch if that's likely to be accepted.

Also, attaching a small patch to update that readme to reflect that gtkprint support needs GTK+ 2.10.

Changed 11 months ago by ojwb

patch to update gtk readme to reflect gtkprint

comment:5 in reply to: ↑ 4 Changed 11 months ago by oneeyeman

Hi,
Replying to ojwb:

pcor: I wasn't proposing to drop support for GTK+ < 2.10, only libgnomeprint.

On that thought though, is it time to drop gtk1 support? According to docs/gtk/readme.txt it's not been maintained since 2.8:

wxWidgets 2.8 still supports GTK+ 1.2, but no developement is done on that port anymore and support for GTK+ 1.2 will probably be dropped entirely.

I'm happy to open a new ticket and prepare a patch if that's likely to be accepted.

Also, attaching a small patch to update that readme to reflect that gtkprint support needs GTK+ 2.10.

There is a system called OpenVMS, which uses GTK+1 and there is at least one person (Jouk Jensen) that uses wxGTK+1.
All tries to port GTK+2 to OpenVMS failed and this system is stuck with {wx}GTK 1.
In fact, I think that Jouk does all the support of wxGTK 1 himself and keeps it compilable under OpenVMS.

comment:6 follow-up: Changed 11 months ago by ojwb

A couple of minutes with a search engine found me a port of GTK2 to OpenVMS:

http://nchrem.tnw.tudelft.nl/openvms/software2.html#GTK2

I have no way of telling how good it is, but it is at least a moderately recent version from the latest 2.x release series - 2.24.9 from January 2012.

comment:7 in reply to: ↑ 6 Changed 11 months ago by oneeyeman

Hi,
Replying to ojwb:

A couple of minutes with a search engine found me a port of GTK2 to OpenVMS:

http://nchrem.tnw.tudelft.nl/openvms/software2.html#GTK2

I have no way of telling how good it is, but it is at least a moderately recent version from the latest 2.x release series - 2.24.9 from January 2012.

Did you look at this: https://groups.google.com/forum/#!topic/comp.os.vms/SPLY0X5QtBQ?
The first post in this thread is from March of 2012 and its the first hit from Google for "openvms gtk2".

It looks like GTK+2 port for OpenVMS is not compilable or at least was not at that time and nobody did anything to bring it on.

Also in that thread you will find a post from Jouk Jensen who does develop on OpenVMS with wxWidgets.

You can probably get more from him if you contact him directly as he works directly with OpenVMS.

Thank you.

comment:8 follow-up: Changed 11 months ago by ojwb

Your first hit in google for a query is not necessarily the same as other people's first hit in google for the same query.

But I notice the contact on the page I linked to is actually Jouk's email address, so he already knows about this port!

comment:9 in reply to: ↑ 8 Changed 11 months ago by oneeyeman

Hi,
Replying to ojwb:

Your first hit in google for a query is not necessarily the same as other people's first hit in google for the same query.

But I notice the contact on the page I linked to is actually Jouk's email address, so he already knows about this port!

Well, to tell you the truth, I don't know.
You best bet is to talk to him. The one thing I do know is that he is still using GTK+1.x on his production system and he keeps GTK1 port of wxWidgets compilable and workable. So my guess is GTK+2 is not ready for production.

But like I said you better talk to him.

comment:10 Changed 11 months ago by VZ

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [74912]) Remove support for Gnome printing from wxGTK.

It was replaced by GTK+ printing several years ago and is almost never used
any longer anyhow, so any problems in this code (and there are some) would
never be found and fixed.

Also update the message catalogs to avoid having the strings not used any
more, as they were only used in Gnome printing code.

Closes #15517.

Note: See TracTickets for help on using tickets.