#15482 closed defect (fixed)

wxX11 requires obsolete pangox library

Reported by: ojwb Owned by:
Priority: normal Milestone:
Component: wxX11 Version: 2.9.5
Keywords: Pango X11 Cc:
Blocked By: Blocking:
Patch: no

Description

wxX11 has a hard dependency on pangox (configure fails without it), but pangox is obsolete upstream.

There's a pangox-compat library available here:

http://ftp.gnome.org/pub/GNOME/sources/pangox-compat/

However, its README indicates that it's really not a good thing to be using:

This is a compatibility library providing the obsolete pangox library
that is not shipped by Pango itself anymore. If you are still using
pangox, well, really, get a life...

Change History (3)

comment:1 Changed 15 months ago by vadz

  • Keywords Pango X11 added
  • Status changed from new to confirmed

I don't even understand how are we using it :-( There is a call to pango_x[ft]_get_context() in src/x11/app.cpp which is relatively straightforward and could probably be replaced by the code getting the Pango context from somewhere else (where?).

But then there is also pango_x.cpp which I have no idea about.

So unfortunately I'm not going to be able to do anything about this before 3.0 personally. Contributions would, of course, be welcome as always.

comment:2 Changed 15 months ago by ojwb

I don't really have a great understanding of these libraries either (this was reported as a Debian bug, though in fact this code isn't used there as we don't package wxX11) but I think it's only the pango_x_* function calls which need replacing - pango_xft_* are from pango-xft, which is a different library, and (AFAIK) not deprecated. So perhaps in src/x11/app.cpp we should just always use the case currently switched on if GDK_USE_XFT is set in the environment.

It doesn't seem like a 3.0 blocker to me - there's pangox-compat for those wanting to use wxX11. I just thought I should report the issue when I became aware of it.

comment:3 Changed 14 months ago by VZ

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [74981]) Don't use long deprecated and now removed pangox library in wxX11 any more.

Use pangoxft only now.

Also remove the apparently unused src/x11/pangox11.cpp file, only
src/x11/pango_x.cpp seems to be used (and this one only by being included in
src/x11/dcclient.cpp).

Closes #15482.

Note: See TracTickets for help on using tickets.