#15218 closed defect (fixed)

wxFilePickerControl::GetPath returns invalid path.

Reported by: lukeg Owned by:
Priority: high Milestone: 2.9.5
Component: wxGTK Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

Every time the path is == wxGetHomeDir() (/home/username)

m_filePicker = new wxFilePickerCtrl(mainPanel, wxID_ANY, wxGetHomeDir());

// ....

void OnButton(wxCommandEvent &event) {
  const wxString path = m_filePicker->GetPath();
  wxLogMessage(path);
}

OS: Fedora 18 x64
wxWidgets: SVN: 74039
Configure: $ ../configure --disable-compat28 --prefix /home/lukasz/.local/

Attachments (1)

fp.cpp download (1.2 KB) - added by lukeg 16 months ago.
wxfilepickerctrl sample

Download all attachments as: .zip

Change History (2)

Changed 16 months ago by lukeg

wxfilepickerctrl sample

comment:1 Changed 16 months ago by VZ

  • Resolution set to fixed
  • Status changed from new to closed

(In [74043]) Fix regression in wxGTK wxFilePickerCtrl due to wxFileDialog changes.

Revert the changes of r72979 and fix wxFileDialog::GetDirectory() return
value bug (see #14786) differently to avoid breaking wxFilePickerCtrl which
relies on getting wxEVT_BUTTON event when the associated dialog is dismissed.

Closes #15218.

Note: See TracTickets for help on using tickets.