Opened 2 years ago

Closed 2 years ago

#15121 closed enhancement (fixed)

Patch: Add support for UAC icon on task dialogs

Reported by: spencercw Owned by:
Priority: normal Milestone: 2.9.5
Component: wxMSW Version: stable-latest
Keywords: wxMessageDialog wxMessageBox auth needed Cc:
Blocked By: Blocking:
Patch: yes

Description

This patch adds a wxICON_AUTH_NEEDED flag for the wxMessageDialog. Obviously it only works on >= Windows Vista; if the task dialog is not in use it falls back to the default icon selection logic. If another icon is specified in addition to wxICON_AUTH_NEEDED then that icon will be used where the task dialog is not available.

Attachments (3)

wxicon_auth_needed.patch download (4.3 KB) - added by spencercw 2 years ago.
wxicon_auth_needed.png download (18.6 KB) - added by spencercw 2 years ago.
icon_auth_needed_v2.patch download (4.8 KB) - added by spencercw 2 years ago.
Updated per review comments

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by spencercw

Changed 2 years ago by spencercw

comment:1 Changed 2 years ago by vadz

  • Milestone set to 2.9.5
  • Status changed from new to confirmed

Thanks for the patch, looks good to me and I'll apply it soon.

The only things that would be worth improving:

  1. Mention that this style is only available since wxWidgets 2.9.5 in the documentation.
  2. Update the "message box" dialog in the dialogs sample to demo this style instead of showing it in the (deprecated) controls sample.

If you could please do it, it would be great, otherwise I'll try to do it myself before applying it.

TIA!

comment:2 Changed 2 years ago by spencercw

Sure thing. I'm at work at the moment but will do it this evening.

Changed 2 years ago by spencercw

Updated per review comments

comment:3 Changed 2 years ago by VZ

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [73877]) Add support for wxICON_AUTH_NEEDED to wxMessageDialog.

Allow showing the standard "Authentication needed" dialog in the message boxes
under MSW.

Closes #15121.

Note: See TracTickets for help on using tickets.