#15013 closed defect (fixed)

Use wxWEBVIEW name instead of wxWEB_VIEW one

Reported by: kosenko Owned by:
Priority: normal Milestone: 2.9.5
Component: WebView Version: stable-latest
Keywords: BadAPI Cc:
Blocked By: Blocking:
Patch: yes

Description

wxWidgets traditionally uses joined widget names without any underscores: CHECKLISTBOX, COMBOBOX, LISTBOX, RADIOBOX, RADIOBUTTON, TEXTCTRL, DATAVIEW and many others. Also there is already wxUSE_WEBVIEW and WXDLLIMPEXP_WEBVIEW macro in the code. So I think wxWEBVIEW should be used instead of wxWEB_VIEW for consistency with other code and patch should be applied before API freeze in 3.0.
Patch also replaces wxWEB_NAV_ERR_* constants with wxWEBVIEW_NAV_ERR_* ones.

Attachments (1)

webview.diff download (74.7 KB) - added by kosenko 18 months ago.

Download all attachments as: .zip

Change History (4)

Changed 18 months ago by kosenko

comment:1 Changed 18 months ago by steve_lamerton

  • Milestone set to 2.9.5
  • Status changed from new to confirmed

I definitely agree that this would be nice to change for consistency, and if we change them it should be as soon as possible, before 2.9.5, so there has only been one official release with the old names.

However I am not sure if we want to break existing code, even if it is very straightforward to fix and gives us more consistency, Vadim?

comment:2 Changed 18 months ago by vadz

I'm not sure neither but I think it's worth applying it, the inconsistency is indeed glaring now that I look at it. We definitely need to mention this in the "INCOMPATIBLE CHANGES SINCE 2.9.4:" section of docs/changes.txt.

comment:3 Changed 18 months ago by SJL

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [73453]) Rename all WEB_VIEW* style identifiers to WEBVIEW*.

This makes wxWebView consistent with the rest of the toolkit.

Closes #15013

Note: See TracTickets for help on using tickets.