Opened 7 years ago

Closed 7 years ago

#14975 closed defect (invalid)

wx.AboutBox on Windows 7 (the version i can confirm atleast)

Reported by: Evilunclebill Owned by:
Priority: normal Milestone:
Component: GUI-all Version: 2.8.12
Keywords: wx.AboutBox Cc:
Blocked By: Blocking:
Patch: no

Description

Hello,

I have encountered a possible “bug” with the widget for windows.
Instead of placing the picture above the text (centered) like it is on Ubuntu (and the tutorial on zetcode) it places the image on the left side.

I have tried with both .ico .png and .jpeg and the icon for the program – same result, the picture shows up on the left side.

Is there any solution for this?

P.S There’s pictures and more text on my question on SO, here: http://stackoverflow.com/questions/14318567/wxpython-aboutdialog-icon-not-centered

Best regards,

Casper

Attachments (2)

Udklip.PNG download (64.4 KB) - added by Evilunclebill 7 years ago.
On Windows
Udklip2.PNG download (34.8 KB) - added by Evilunclebill 7 years ago.
On Ubuntu (zetcode tutorial)

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Evilunclebill

On Windows

Changed 7 years ago by Evilunclebill

On Ubuntu (zetcode tutorial)

comment:1 Changed 7 years ago by vadz

  • Resolution set to invalid
  • Status changed from new to closed

It's not a bug, it's an attempt to approximate the native behaviour. There is no well-defined standard for the about box under Windows but the most usual layout puts the icon to the left.

More generally speaking, wxAboutBox doesn't make any guarantees about its appearance under the given platform as it wraps the native dialog if available. If you need something looking in the same way under all platforms you can always (easily) use a generic dialog in your own code.

Note: See TracTickets for help on using tickets.