Opened 2 years ago

Closed 2 years ago

#14948 closed defect (fixed)

wxGrid example autosize does not work correctly

Reported by: hackish Owned by:
Priority: normal Milestone:
Component: samples Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

I started with a fresh MSW install of 2.9.

Here are the steps to reproduce the problem:
Run the griddemo sample program (/samples/grid)
From the autosize menu select "Entire Grid"

The grid will repaint itself over the entire containing window. Since I've never had a lot of luck with sizers I can't tell if this is a defect in the sample or wxGrid.

Attachments (1)

gridsample.jpg download (105.5 KB) - added by hackish 2 years ago.
Showing the autosize problem

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by hackish

Showing the autosize problem

comment:1 Changed 2 years ago by VZ

  • Resolution set to fixed
  • Status changed from new to closed

(In [73343]) Re-lay out the grid sample window after auto-sizing the grid.

Changing the size of the grid without updating the sizer resulted in
overlapping windows and a mess on the display.

Closes #14948.

Note: See TracTickets for help on using tickets.