#14864 closed enhancement (fixed)

Ribbon bar drop down arrow disabled colour

Reported by: wxBen Owned by:
Priority: low Milestone:
Component: GUI-all Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: yes

Description

A while back an option was added to the ribbon bar to use a disabled text colour for disabled items. That works well, except buttons with drop down arrows still draw the arrow in the original non disabled colour, making them stand out.

This patch extends the use of the disabled colour to the down arrows as well.

This change only takes effect if the user sets a disabled colour, since it defaults to the regular colour.

Attachments (1)

DownArrowColour.diff download (1.7 KB) - added by wxBen 23 months ago.
DownArrowColour.diff

Download all attachments as: .zip

Change History (5)

comment:1 Changed 23 months ago by vadz

  • Priority changed from normal to low
  • Status changed from new to confirmed

Would it be possible to avoid code duplication by adding a function for drawing this arrow and reusing it?

comment:2 Changed 23 months ago by wxBen

I dislike the code duplication as well. Is this version more acceptable?

Changed 23 months ago by wxBen

DownArrowColour.diff

comment:3 Changed 23 months ago by vadz

It's better, thanks, but as long as we're doing it like this we could reduce the duplication even a bit more, will commit soon.

comment:4 Changed 23 months ago by VZ

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [73086]) Use disabled colour for the dropdown arrow of disabled ribbon.

Previously the normal colour was used for the arrow in MSW art provider even
if the ribbon was disabled.

Closes #14864.

Note: See TracTickets for help on using tickets.