#14838 closed enhancement (fixed)

wxTreeListCtrl: Add style wxTL_NO_HEADER

Reported by: robboto Owned by:
Priority: low Milestone:
Component: GUI-generic Version: stable-latest
Keywords: wxTreeListCtrl, wxDV_NO_HEADER docs-needed Cc:
Blocked By: Blocking:
Patch: yes

Description

The attached patch adds the style wxTL_NO_HEADER to wxTreeList, which is simply passed through as wxDV_NO_HEADER to the wxDataViewCtrl used inside wxTreeList.

Would be great to have this in 2.9.5

Attachments (2)

treelist.patch download (2.7 KB) - added by robboto 22 months ago.
treelist.2.patch download (2.7 KB) - added by robboto 22 months ago.

Download all attachments as: .zip

Change History (6)

Changed 22 months ago by robboto

comment:1 Changed 22 months ago by vadz

  • Keywords docs-needed added
  • Priority changed from normal to low
  • Status changed from new to confirmed

Could you please update interface/wx/treelist.h accordingly? Please mention that this style is new using "@since 2.9.5" there.

comment:2 Changed 22 months ago by robboto

Actually I did...
...but in the wrong file ;-)

updated patch

Changed 22 months ago by robboto

comment:3 Changed 22 months ago by vadz

I'll commit it but please check compilation of your patches (at least...) before submitting them because there is a missing parentheses in the code which broke it this time. TIA!

comment:4 Changed 22 months ago by VZ

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [72990]) Add wxTL_NO_HEADER style to wxTreeListCtrl.

Closes #14838.

Note: See TracTickets for help on using tickets.