#14801 closed defect (fixed)

wxDVC collapses invisible root item

Reported by: rk Owned by:
Priority: normal Milestone:
Component: GUI-generic Version: stable-latest
Keywords: wxDataViewCtrl Cc:
Blocked By: Blocking:
Patch: yes

Description

In r72325 code was added that collapses items that become empty. Unfortunately this also happens for the invisible root item. The problem is that it is impossible to expand this item again. The attached patch fixes this by making sure that the internal root node of the tree can never be collapsed.

Attachments (1)

dvctl_root_node_collapse_fix.diff download (1.2 KB) - added by rk 23 months ago.

Download all attachments as: .zip

Change History (2)

Changed 23 months ago by rk

comment:1 Changed 23 months ago by VZ

  • Resolution set to fixed
  • Status changed from new to closed

(In [72905]) Never collapse invisible root item in generic wxDataViewCtrl.

Since the changes of r72325, the root item could be collapsed and marked as
not having any children but this was wrong because no items could be added to
it after this.

Just ignore any attempts to collapse it.

Closes #14801.

Note: See TracTickets for help on using tickets.