#14736 closed defect (fixed)

AUI window is not resizable under GTK3

Reported by: Klaus82 Owned by:
Priority: normal Milestone:
Component: wxAui Version: 2.9.4
Keywords: gtk3 aui ubuntu Cc:
Blocked By: Blocking:
Patch: no

Description

If I run the AUI samples and drag a pane outside the parent window, I can not resize it.
Under MSW and GTK2 it seems to work, but not under GTK3.

Change History (5)

comment:1 Changed 22 months ago by pcor

  • Status changed from new to infoneeded_new

Seems to work fine for me with GTK 3.2.4 and XFCE. I can undock the pane titled "Tree Pane", drag it outside the frame, and resize it. If you are doing something different with the sample, please describe exactly what that is. And what GTK version and desktop environment are you using?

comment:2 Changed 22 months ago by Klaus82

  • Status changed from infoneeded_new to new

I do the same. Undock the tree, but I cannot resize it.

I am using Ubuntu with the GTK-3 port.

Distributor ID:	Ubuntu
Description:	Ubuntu 12.04.1 LTS
Release:	12.04
Codename:	precise

Perhaps it has something to do with my GTK3 Version. It is the one which was shipped with Ubuntu and it is named libgtk-3-0. I do not know if the version number is comparable to yours, but it is for sure older.

comment:3 Changed 22 months ago by jens

I just installed ubuntu 12.04 on a vm to test it.
I can confirm the problem, but it seems to be a theming issue.

The main window of the auidemo itself can not be resized also, at least not with simple dragging of a border or corner.
It still works from context-menu of the window-title and with "ALT+F8" shortcut.
The shortcut also works for the undocked pane.

The high-contrast themes still have the resize-gripper in the lower right corner, but the default theme (ambiance) and the other "fancy" theme (radi???) both do not have/draw this gripper.

Jens

comment:4 Changed 21 months ago by vadz

  • Keywords ubuntu added
  • Milestone 2.9.5 deleted

Can the problem be reproduced with non-AUI windows? Also, does it happen only with Unity or under other desktop environments used in Ubuntu too?

comment:5 Changed 21 months ago by pcor

  • Resolution set to fixed
  • Status changed from new to closed

I think this was fixed by r72949

Note: See TracTickets for help on using tickets.