Opened 2 years ago

Closed 23 months ago

#14703 closed enhancement (fixed)

Add assign() to wxVector, to conform with std::vector

Reported by: jonasr Owned by:
Priority: normal Milestone:
Component: base Version:
Keywords: docs-needed Cc:
Blocked By: Blocking:
Patch: yes

Description

Hi

A small addition to wxVector that's missing, compared to http://www.cplusplus.com/reference/stl/vector/

Attachments (1)

vectorassign.patch download (951 bytes) - added by jonasr 2 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 2 years ago by vadz

  • Keywords docs-needed added
  • Status changed from new to confirmed

Could you please also update interface/wx/vector.h? Please use "@since 2.9.5" in the method documentation.

TIA!

Changed 2 years ago by jonasr

comment:2 Changed 23 months ago by jonasr

Bump.

The docs are added in the patch, is there anything else that needs to be fixed? Or perhaps just an oversight.

Regards
Jonas

comment:3 Changed 23 months ago by vadz

Oversight, sorry, I've somehow missed the addition of the patch.

Will commit soon, thanks!

comment:4 Changed 23 months ago by VZ

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [72748]) Add wxVector::assign().

Closes #14703.

Note: See TracTickets for help on using tickets.