Opened 4 years ago

Closed 10 months ago

#14127 closed enhancement (fixed)

wxColorDialog and wxColorPicker should support option for Alpha

Reported by: Hanmac Owned by: Vadim Zeitlin <vadim@…>
Priority: low Milestone:
Component: GUI-all Version: stable-latest
Keywords: wxColourDialog alpha Cc:
Blocked By: Blocking:
Patch: no

Description

colorpicker and colordialog should have an setter&getter in the ColorData object that enables the alpha-slider in the colordialog.
gtk support this, and it may be a way to support it in generic (and others)

Attachments (4)

wxColourDialog_GTK.png download (36.8 KB) - added by awi 10 months ago.
wxColourDialog with opacity slider (GTK)
wxColourPicker_GTK2.png download (34.4 KB) - added by awi 10 months ago.
wxColourPicker with opacity slider (GTK2).
wxColourPicker_GTK3.png download (23.4 KB) - added by awi 10 months ago.
wxColourPicker with opacity slider (GTK3).
wxGenericColourDialog.png download (18.2 KB) - added by awi 10 months ago.
wxGenericColourDialog

Download all attachments as: .zip

Change History (11)

comment:1 Changed 4 years ago by vadz

  • Keywords wxColourDialog alpha added; ColourDialog Alpha removed
  • Status changed from new to confirmed

comment:2 Changed 3 years ago by SC

(In [73638]) add support for alpha in color dialog on OSX, see #14127

comment:3 Changed 3 years ago by SC

(In [73640]) support alpha in color dialog, see #14127

comment:4 Changed 10 months ago by awi

PR with modifications to add alpha channel support on wxGTK: PR120.

wxColourDialog with opacity slider (GTK)
wxColourPicker with opacity slider (GTK2).
wxColourPicker with opacity slider (GTK3).

Changed 10 months ago by awi

wxColourDialog with opacity slider (GTK)

Changed 10 months ago by awi

wxColourPicker with opacity slider (GTK2).

Changed 10 months ago by awi

wxColourPicker with opacity slider (GTK3).

comment:5 Changed 10 months ago by awi

PR with modifications to add alpha channel support to wxGenericColourDialog: PR121
Opacity level is controlled by additional slider and colour preview (with alpha) is implemented with wxStaticBox controls.
wxGenericColourDialog

Changed 10 months ago by awi

wxGenericColourDialog

comment:6 Changed 10 months ago by vadz

This was merged as ac0505e7d838eb414d903c3a40621f3ff83bf8b7/git-wxWidgets but Trac has unfortunately missed this commit, somehow.

Still leaving this open because of the GTK part.

comment:7 Changed 10 months ago by Vadim Zeitlin <vadim@…>

  • Owner set to Vadim Zeitlin <vadim@…>
  • Resolution set to fixed
  • Status changed from confirmed to closed

In e58e3f67aaecf8bd74ccf9bf8c6b24435cb29016/git-wxWidgets:

Merge branch 'colour_dialogs_alpha' of https://github.com/a-wi/wxWidgets

Add support for alpha channel to wxColourPicker and wxColourDialog in wxGTK.

Closes #14127.

Note: See TracTickets for help on using tickets.