Opened 9 years ago

Closed 9 years ago

#13740 closed defect (fixed)

MSW: GUI widgets in wxPopupTransientWindow cannot be used

Reported by: koichi Owned by: vadz
Priority: normal Milestone: 2.9.3
Component: wxMSW Version:
Keywords: wxPopupTransientWindow, regression Cc:
Blocked By: Blocking:
Patch: no

Description

The bug can be reproduced with the popup sample.
This regression seems to be introduced during October 2011 or so.

Change History (2)

comment:1 Changed 9 years ago by vadz

  • Milestone set to 2.9.3
  • Owner set to vadz
  • Status changed from new to accepted

Oops, yes, this was broken by r69350 for the mouse input (keyboard didn't work even before and I'm not sure if it ever worked in fact). The problem seems to be that we now prevent the buttons inside the popup from capturing the mouse although I'm not quite sure why exactly does this happen...

comment:2 Changed 9 years ago by VZ

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [69966]) Restore mouse capturing/releasing in wxPopupTransientWindow under MSW.

Partially revert the changes of r69350 to restore EVT_IDLE handling of
wxPopupTransientWindow under MSW. It turns out that we must release the mouse
for the embedded controls to work.

It would be better to solve the problem differently, e.g. perhaps maybe only
releasing mouse capture when mouse is clicked as the current code is fragile
but for now at least restore the functionality that used to work.

Closes #13740.

Note: See TracTickets for help on using tickets.