Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13505 closed defect (fixed)

Win2008 VNC 4 and standard dialogs sample

Reported by: Hexamail Owned by:
Priority: normal Milestone:
Component: wxMSW Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

Under Windows 2008 (maybe other platforms) the dialogs sample app shows standard popup dialogs as very small/invsisible if a VNC session is started during the lifetime of the sample dialogs app.

This only happens if the VNC Server option Optimize Screen Capture is enabled

To reproduce:
1) Install VNC Server (tested with v4) with default settings
2) Open the Dialogs sample application
3) Open a messagebox
4) close messagebox
5) connect from a remote vncclient
6) Open the messagebox - it wont show but the app loses focus, so the dialog is created small/invisible
7) press ESC/RETURN to close the dialog
8) EXIT and reopen the dialogs sample application
9) Open messagebox - it now works.

So its something to do with the wxwidgets framework not handling some sort of screen/display size/redirection message during the lifetime of an application.

A video (3MB) showing the problem is here:
http://www.hexamail.com/download/test/Win2008x64VNC.avi

If anyone can point us in the right direction as to where the issue may lie we can investigate further, but our knowledge of Windows DC/display drivers is limited and we can't see anything obviously wrong.

Change History (2)

comment:1 Changed 3 years ago by vadz

  • Resolution set to fixed
  • Status changed from new to closed

I think this should have been fixed by r69171, please retest with latest svn.

comment:2 Changed 3 years ago by Hexamail

We can confirm this is fixed. Thank you.

Note: See TracTickets for help on using tickets.