Opened 3 years ago

Closed 20 months ago

#13241 closed defect (outdated)

TCP socket events get lost

Reported by: Stu Redman Owned by:
Priority: normal Milestone:
Component: network Version: stable-latest
Keywords: socket wxMSW regression Cc: sturedman@…
Blocked By: Blocking:
Patch: no

Description

I noticed aMule performs poorly with current wx SVN in Windows.
It works in principle, but most TCP network connections fail and clients appear to be unreachable. aMule works fine with wx 2.8.12 or wx SVN in Linux.

Kry suggested to try to revert 64565, and this fixes the problem. So this change apparently makes wx ignore a lot of valid events.

Platform is Windows 7 x64.

Change History (4)

comment:1 Changed 3 years ago by Kry

  • Status changed from new to confirmed

I am working on this as we speak, along with other wxSocket needed changed to address the rest of the tickets.

This problem in particular, which was caused by a patch introduced to solve a different ticket, is taking a bit to analyze as I want to undo the patch and fix the underlying reason for the previous ticket ( #11528 )

comment:2 Changed 2 years ago by vadz

  • Keywords regression added
  • Patch unset
  • Status changed from confirmed to infoneeded_new

Unfortunately I don't know how to fix this neither. Just reverting r64565 is a bad idea as it would make the bug fixed by it reappear. And I also am not sure how exactly does it fix the problem, if there is nothing to read on the socket, what do we need the notification for?

It would be great to be able to reproduce this problem in the socket sample somehow. Without this I don't know how are we going to be able to debug it... Could you please let us know what is special/different from the sample about aMule and in which conditions exactly is this missing notification important?

comment:3 Changed 2 years ago by Stu Redman

  • Cc sturedman@… added
  • Status changed from infoneeded_new to new

I retried aMule with wx 2.9.3, and here it works fine without reverting the changeset. No idea what change caused the different behavior.

comment:4 Changed 20 months ago by vadz

  • Resolution set to outdated
  • Status changed from new to closed

OK, thanks for testing.

Note: See TracTickets for help on using tickets.