Opened 9 years ago

Closed 9 years ago

#12887 closed defect (duplicate)

Can't build universal binary with snapshot

Reported by: snowleopard2 Owned by:
Priority: normal Milestone:
Component: build Version: stable-latest
Keywords: Cc:
Blocked By: Blocking:
Patch: no

Description

When I try to build wx as a universal binary with this config:

configure CC=gcc-4.0 CXX=g++-4.0 LD=g++-4.0 --with-macosx-sdk=/Developer/SDKs/MacOSX10.4u.sdk --with-osx_cocoa --with-macosx-version-min=10.4 --disable-shared --enable-universal_binary --disable-debug_flag

I get these errors:

./src/common/arrstr.cpp
/Developer/SDKs/MacOSX10.4u.sdk/usr/include/c++/4.0.0/bits/stl_algo.h: In function ‘void std::__final_insertion_sort(_RandomAccessIterator, _RandomAccessIterator, _Compare) [with _RandomAccessIterator = wxString*, _Compare = wxSortPredicateAdaptor]’:
/Developer/SDKs/MacOSX10.4u.sdk/usr/include/c++/4.0.0/bits/stl_algo.h:2608:   instantiated from ‘void std::sort(_RandomAccessIterator, _RandomAccessIterator, _Compare) [with _RandomAccessIterator = wxString*, _Compare = wxSortPredicateAdaptor]’
'''./src/common/arrstr.cpp:418:   instantiated from here'''

I know GCC 4.0 has troubles with reverse_iterators (even in perfectly valid code). It may be necessary to change this to use forward iterators to get this to compile.

Change History (1)

comment:1 Changed 9 years ago by csomor

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #12689

Note: See TracTickets for help on using tickets.