Changes between Initial Version and Version 1 of Ticket #12886, comment 16


Ignore:
Timestamp:
Mar 27, 2016, 5:30:41 PM (4 years ago)
Author:
dandi
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #12886, comment 16

    initial v1  
    11Recently I came across this bug or something that seems to be related to this issue.
    22
    3 My issue looks the same: I have GUI and a worker thread that uses wxHTTP. After running the worker thread several times, it crashes (sometimes with SEG_FAULT, sometimes with "invalid socket" as in #10720).
     3My issue looks the same: I have GUI and a worker thread that uses wxHTTP. After running the worker thread several times, it crashes (sometimes with SIGSEGV, sometimes with "invalid socket" as in #10720).
    44
    55I was using 3.0.2 from debian repositories. However, when I link my project against the latest version from git, everything seems to work fine, at least for the first ten runs. So I went further and wrote a simple test with GUI and a worker thread that creates, uses, and destroys wxHTTP in a loop. This test shows the same behavior as my big project: being linked against 3.0.2, it crashes during the first ten iterations, but if linked against 3.1.1, it runs perfectly for the first few thousands iterations (I didn't have patience to run it longer).
    66
    7 Were there any changes related to this issue? Maybe this ticket and related #10720 can be marked as solved?
     7Were there any changes related to this issue? Maybe this ticket and related #10720 can be closed?